diff configure.ac @ 14511:f309a5b3f184

[gaim-migrate @ 17231] Switched from using libdbi to using sqlite3. Results in easier configuration (no need to setup database server/create database/add tables). Also Gtk Gaim no longer needs to link against libdbi. This should make the plugin more easily distributable and thus hopefully it can be included in binary releases of Gaim (fingers crossed). committer: Tailor Script <tailor@pidgin.im>
author Geoff Foster <g-off_>
date Mon, 11 Sep 2006 00:28:35 +0000
parents ca36763497d9
children 82b59abcaee4
line wrap: on
line diff
--- a/configure.ac	Sun Sep 10 22:33:28 2006 +0000
+++ b/configure.ac	Mon Sep 11 00:28:35 2006 +0000
@@ -324,12 +324,10 @@
 	fi
 
 	dnl #######################################################################
-	dnl # Check for libdbi (for the Contact Availability Prediction plugin)
+	dnl # Check for libsqlite3 (for the Contact Availability Prediction plugin)
 	dnl #######################################################################
 	if test "x$enable_cap" = "xyes"; then
-		AC_CHECK_HEADERS(dbi/dbi.h, , enable_cap="no")
-		AC_CHECK_LIB(dbi, dbi_result_field_is_null, CAP_LIBS="-ldbi", enable_cap="no")
-		AC_SUBST(CAP_LIBS)
+		PKG_CHECK_MODULES(SQLITE3, sqlite3 >= 3.3, , enable_cap="no")
 	fi
 
 else # GTK