diff Makefile.am @ 20912:f34539eb7a61

Add some xsl magic to generate a .devhelp index from doxygen's XML output, allowing the documentation to be viewed in Devhelp. It's not perfect --- there are some broken links and the transformation is a bit fragile --- but works well enough to be useful.
author Will Thompson <will.thompson@collabora.co.uk>
date Sat, 13 Oct 2007 15:44:43 +0000
parents 4c26b23e7859
children a97f24eda509
line wrap: on
line diff
--- a/Makefile.am	Fri Oct 12 22:26:44 2007 +0000
+++ b/Makefile.am	Sat Oct 13 15:44:43 2007 +0000
@@ -48,6 +48,13 @@
 if HAVE_DOXYGEN
 	@echo "Running doxygen..."
 	@doxygen
+if HAVE_XSLTPROC
+	@echo "Generating devhelp index..."
+	@xsltproc doxy2devhelp.xsl doc/xml/index.xml > doc/html/pidgin.devhelp
+	@echo "(Symlink doc/html to ~/.local/share/gtk-doc/html/pidgin to make devhelp see the documentation)"
+else
+	@echo "Not generating devhelp index: xsltproc was not found by configure"
+endif
 else
 	@echo "doxygen was not found during configure.  Aborting."
 	@echo;