diff Makefile.am @ 11862:f8cd06753755

[gaim-migrate @ 14153] Make "make distcheck" work, which also makes the perl plugin loader loadable when installed to a non-standard prefix (it still can't find Gaim.pm though) Add some extra warning CFLAGS if a) --enable-debug was used and b) your compiler supports them. Plug a couple of leaks The gaimrc plugin's GtkTreeView expander_size setting now works (but doesn't seem to instant-apply - should it?) staticify some functions that don't need to be exposed probably something else I forgot about committer: Tailor Script <tailor@pidgin.im>
author Stu Tomlinson <stu@nosnilmot.com>
date Thu, 27 Oct 2005 20:43:43 +0000
parents 616feca04ada
children d8128936c2f1
line wrap: on
line diff
--- a/Makefile.am	Thu Oct 27 20:22:27 2005 +0000
+++ b/Makefile.am	Thu Oct 27 20:43:43 2005 +0000
@@ -48,3 +48,9 @@
 	@echo "doxygen was not found during configure.  Aborting."
 	@echo;
 endif
+
+# perl's MakeMaker uninstall foo doesn't work well with DESTDIR set, which
+# breaks "make distcheck" unless we ignore perl things
+
+distuninstallcheck_listfiles = \
+	find . -type f -print | grep -v perl