diff gtk/plugins/Makefile.am @ 14191:009db0b357b5

This is a hand-crafted commit to migrate across subversion revisions 16854:16861, due to some vagaries of the way the original renames were done. Witness that monotone can do in one revision what svn had to spread across several.
author Ethan Blanton <elb@pidgin.im>
date Sat, 16 Dec 2006 04:59:55 +0000
parents
children 60b1bc8dbf37
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/gtk/plugins/Makefile.am	Sat Dec 16 04:59:55 2006 +0000
@@ -0,0 +1,86 @@
+DIST_SUBDIRS = docklet gevolution gestures musicmessaging ticker
+
+if BUILD_GEVOLUTION
+GEVOLUTION_DIR = gevolution
+endif
+
+if ENABLE_DBUS
+MUSICMESSAGING_DIR = musicmessaging
+endif
+
+SUBDIRS = \
+	docklet \
+	$(GEVOLUTION_DIR) \
+	gestures \
+	$(MUSICMESSAGING_DIR) \
+	ticker
+
+plugindir = $(libdir)/gaim
+
+extplacement_la_LDFLAGS     = -module -avoid-version $(GLIB_LIBS)
+gaimrc_la_LDFLAGS           = -module -avoid-version $(GTK_LIBS)
+history_la_LDFLAGS          = -module -avoid-version $(GTK_LIBS)
+iconaway_la_LDFLAGS         = -module -avoid-version $(GTK_LIBS)
+notify_la_LDFLAGS           = -module -avoid-version $(GTK_LIBS)
+relnot_la_LDFLAGS           = -module -avoid-version $(GLIB_LIBS)
+spellchk_la_LDFLAGS         = -module -avoid-version $(GTK_LIBS)
+timestamp_la_LDFLAGS        = -module -avoid-version $(GTK_LIBS)
+timestamp_format_la_LDFLAGS = -module -avoid-version $(GTK_LIBS)
+
+if PLUGINS
+
+plugin_LTLIBRARIES = \
+	extplacement.la     \
+	gaimrc.la           \
+	history.la          \
+	iconaway.la         \
+	notify.la           \
+	relnot.la           \
+	spellchk.la         \
+	timestamp.la        \
+	timestamp_format.la
+
+
+extplacement_la_SOURCES     = extplacement.c
+gaimrc_la_SOURCES           = gaimrc.c
+history_la_SOURCES          = history.c
+iconaway_la_SOURCES         = iconaway.c
+notify_la_SOURCES           = notify.c
+relnot_la_SOURCES           = relnot.c
+spellchk_la_SOURCES         = spellchk.c
+timestamp_la_SOURCES        = timestamp.c
+timestamp_format_la_SOURCES = timestamp_format.c
+
+endif # PLUGINS
+
+EXTRA_DIST = \
+	ChangeLog HOWTO \
+	ChangeLog.API \
+	Makefile.mingw \
+	contact_priority.c \
+	gaiminc.c \
+	gtk-signals-test.c \
+	mailchk.c \
+	raw.c
+
+AM_CPPFLAGS = \
+	-DDATADIR=\"$(datadir)\" \
+	-DVERSION=\"$(VERSION)\" \
+	-I$(top_builddir)/src \
+	-I$(top_srcdir)/core \
+	-I$(top_srcdir)/gtk \
+	$(DEBUG_CFLAGS) \
+	$(GTK_CFLAGS) \
+	$(PLUGIN_CFLAGS)
+
+#
+# This part allows people to build their own plugins in here.
+# Yes, it's a mess.
+#
+SUFFIXES = .c .so
+.c.so:
+	$(LIBTOOL) --mode=compile $(CC) -DHAVE_CONFIG_H -I$(top_srcdir) $(AM_CPPFLAGS) $(CFLAGS) -c $< -o tmp$@.lo $(PLUGIN_CFLAGS)
+	$(LIBTOOL) --mode=link    $(CC) $(CFLAGS) -o libtmp$@.la -rpath $(plugindir) tmp$@.lo $(LIBS) $(LDFLAGS) -module -avoid-version $(PLUGIN_LIBS)
+	@rm -f tmp$@.lo tmp$@.o libtmp$@.la
+	@cp .libs/libtmp$@.so* $@
+	@rm -f .libs/libtmp$@.*