diff finch/plugins/Makefile.am @ 15817:0e3a8505ebbe

renamed gaim-text to finch
author Sean Egan <seanegan@gmail.com>
date Sun, 18 Mar 2007 19:38:15 +0000
parents
children c6e563dfaa7a
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/finch/plugins/Makefile.am	Sun Mar 18 19:38:15 2007 +0000
@@ -0,0 +1,51 @@
+gntgf_la_LDFLAGS      = -module -avoid-version
+gnthistory_la_LDFLAGS = -module -avoid-version
+gntlastlog_la_LDFLAGS    = -module -avoid-version
+
+if PLUGINS
+
+plugin_LTLIBRARIES = \
+	gntgf.la \
+	gnthistory.la \
+	gntlastlog.la
+
+plugindir = $(libdir)/gaim
+
+gntgf_la_SOURCES      = gntgf.c
+gnthistory_la_SOURCES = gnthistory.c
+gntlastlog_la_SOURCES = lastlog.c
+
+gntgf_la_CFLAGS = $(X11_CFLAGS)
+
+gntgf_la_LIBADD       = $(GLIB_LIBS) $(X11_LIBS) $(top_builddir)/finch/libgnt/libgnt.la
+gnthistory_la_LIBADD  = $(GLIB_LIBS)
+gntlastlog_la_LIBADD  = $(GLIB_LIBS)
+
+endif # PLUGINS
+
+EXTRA_DIST = 
+
+AM_CPPFLAGS = \
+	-DDATADIR=\"$(datadir)\" \
+	-DVERSION=\"$(VERSION)\" \
+	-I$(top_builddir)/libpurple \
+	-I$(top_srcdir)/libpurple \
+	-I$(top_srcdir) \
+	-I$(top_srcdir)/finch \
+	-I$(top_srcdir)/finch/libgnt \
+	$(DEBUG_CFLAGS) \
+	$(GLIB_CFLAGS) \
+	$(GNT_CFLAGS) \
+	$(PLUGIN_CFLAGS)
+
+#
+# This part allows people to build their own plugins in here.
+# Yes, it's a mess.
+#
+SUFFIXES = .c .so
+.c.so:
+	$(LIBTOOL) --mode=compile $(CC) -DHAVE_CONFIG_H -I$(top_srcdir) $(AM_CPPFLAGS) $(CFLAGS) -c $< -o tmp$@.lo $(PLUGIN_CFLAGS)
+	$(LIBTOOL) --mode=link    $(CC) $(CFLAGS) -o libtmp$@.la -rpath $(plugindir) tmp$@.lo $(LIBS) $(LDFLAGS) -module -avoid-version $(PLUGIN_LIBS)
+	@rm -f tmp$@.lo tmp$@.o libtmp$@.la
+	@cp .libs/libtmp$@.so* $@
+	@rm -f .libs/libtmp$@.*