diff plugins/Makefile.am @ 11337:1462b64f8fc9

[gaim-migrate @ 13550] Files dbus-types.? are now generated automatically committer: Tailor Script <tailor@pidgin.im>
author Piotr Zielinski <zielaj>
date Thu, 25 Aug 2005 00:27:12 +0000
parents 519dc2186438
children a6d446cf090f
line wrap: on
line diff
--- a/plugins/Makefile.am	Wed Aug 24 20:45:20 2005 +0000
+++ b/plugins/Makefile.am	Thu Aug 25 00:27:12 2005 +0000
@@ -68,11 +68,16 @@
 dbus_example_la_SOURCES = dbus-example.c
 plugin_LTLIBRARIES     += dbus-example.la
 
-dbus-example-bindings.c: ../src/dbus-analyze-functions.py $(dbus_example_la_SOURCES) $(dbus_example_la_HEADERS)
+.PHONY: always
+
+$(top_builddir)/src/dbus-types.h: always
+	cd $(@D) && $(MAKE) $(AM_MAKEFLAGS) $(@F)
+
+dbus-example-bindings.c: $(top_srcdir)/src/dbus-analyze-functions.py $(dbus_example_la_SOURCES) $(dbus_example_la_HEADERS)
 	cat $(dbus_example_la_SOURCES) $(dbus_example_la_HEADERS) | \
-	$(PYTHON) ../src/dbus-analyze-functions.py --export-only > $@
+	$(PYTHON) $(top_srcdir)/src/dbus-analyze-functions.py --export-only > $@
 
-$(dbus_example_la_OBJECTS) dbus-example.so: dbus-example-bindings.c
+$(dbus_example_la_OBJECTS) dbus-example.so: dbus-example-bindings.c $(top_builddir)/src/dbus-types.h
 
 
 endif # ENABLE_DBUS