diff src/Makefile.am @ 11337:1462b64f8fc9

[gaim-migrate @ 13550] Files dbus-types.? are now generated automatically committer: Tailor Script <tailor@pidgin.im>
author Piotr Zielinski <zielaj>
date Thu, 25 Aug 2005 00:27:12 +0000
parents 681870123ce3
children 2de0bf90a474
line wrap: on
line diff
--- a/src/Makefile.am	Wed Aug 24 20:45:20 2005 +0000
+++ b/src/Makefile.am	Thu Aug 25 00:27:12 2005 +0000
@@ -149,13 +149,13 @@
 
 if ENABLE_DBUS
 
-CLEANFILES    = \
+CLEANFILES = \
 	dbus-bindings.c \
 	dbus-client-binding.c \
 	dbus-client-binding.h \
-	gaim.service
-#	dbus-types.c 
-#	dbus-types.h 
+	gaim.service \
+	dbus-types.c \
+	dbus-types.h 
 
 # gaim dbus server
 
@@ -164,19 +164,12 @@
 
 dbus_exported = dbus-useful.h dbus-define-api.h account.h blist.h connection.h conversation.h core.h roomlist.h status.h server.h
 
-#Although dbus-types.[ch] are generated automatically, they are
-#included in the distribution (and CVS) as normal source
-#files. Otherwise, we would have to compile the src directory before
-#the plugins directory, because some of the plugins depend on the
-#dbus-types.h.  On the other hand, gaim-remote from the src directory
-#requires libgaim-remote from the the plugins directory, which forces
-#us to compile the plugins directory before src.  
 
-# dbus-types.c: dbus-analyze-types.py $(gaim_coreheaders)
-# 	cat $(gaim_coreheaders) | $(PYTHON) dbus-analyze-types.py --pattern=GAIM_DBUS_DEFINE_TYPE\(%s\) > $@
+dbus-types.c: dbus-analyze-types.py $(gaim_coreheaders)
+	cat $(gaim_coreheaders) | $(PYTHON) dbus-analyze-types.py --pattern=GAIM_DBUS_DEFINE_TYPE\(%s\) > $@
 
-# dbus-types.h: dbus-analyze-types.py $(dbus_coreheaders)
-# 	cat $(gaim_coreheaders) | $(PYTHON) dbus-analyze-types.py --pattern=GAIM_DBUS_DECLARE_TYPE\(%s\) > $@
+dbus-types.h: dbus-analyze-types.py $(dbus_coreheaders)
+	cat $(gaim_coreheaders) | $(PYTHON) dbus-analyze-types.py --pattern=GAIM_DBUS_DECLARE_TYPE\(%s\) > $@
 
 dbus-bindings.c: dbus-analyze-functions.py $(dbus_exported)
 	cat $(dbus_exported) | $(PYTHON) dbus-analyze-functions.py > $@