diff finch/libgnt/wms/Makefile.am @ 17989:1bccb9641ef3

Add a new WM, irssi. Put the wm's in $(libdir)/gnt instead of in /finch. The features of the irssi WM include: 1. Buddylist and conversation windows are borderless and full height of the screen. 2. Conversation windows will have (full-screen-width - buddylist-width) width - It's possible to auto-resize the conversation windows when the buddylist is closed/opened/resized to keep this always true. But resizing the textview in conversation window is rather costly, especially when there's a lot of text in the scrollback. So it's not done yet. 3. All the other windows are always centered.
author Sadrul Habib Chowdhury <imadil@gmail.com>
date Sat, 02 Jun 2007 03:49:53 +0000
parents 0dcd915899ae
children f63e38e33811
line wrap: on
line diff
--- a/finch/libgnt/wms/Makefile.am	Fri Jun 01 23:41:12 2007 +0000
+++ b/finch/libgnt/wms/Makefile.am	Sat Jun 02 03:49:53 2007 +0000
@@ -1,9 +1,16 @@
 s_la_LDFLAGS             = -module -avoid-version
+irssi_la_LDFLAGS         = -module -avoid-version
 
 plugin_LTLIBRARIES = \
-	s.la
+	s.la \
+	irssi.la
+
+plugindir = $(libdir)/gnt
 
-plugindir = $(libdir)/finch
+irssi_la_SOURCES = irssi.c
+irssi_la_LIBADD =  \
+  $(GLIB_LIBS) \
+  $(top_builddir)/finch/libgnt/libgnt.la
 
 s_la_SOURCES = s.c
 s_la_LIBADD =  \