diff libpurple/protocols/bonjour/Makefile.am @ 24389:2b62300d2c19

Use libtool to build static archives when --with-static-prpls is passed to configure. Does anyone know why we weren't using libtool before? We were building old-fashioned .a files. But libtool archives (.la) can contain either static or shared libraries. I found it a lot easier to get static prpl compilation working after making this change (that is to say, it worked). Without this I got this error, which is probably fixable, but consistently using libtool seems like it makes things easier: *** Warning: Linking the shared library libpurple.la against the *** static library ../libpurple/protocols/msn/libmsn.a is not portable! /usr/bin/ld: ../libpurple/protocols/msn/libmsn.a(libmsn_a-msn.o): relocation R_X86_64_32 against `a local symbol' can not be used when making a shared object; recompile with -fPIC ../libpurple/protocols/msn/libmsn.a: could not read symbols: Bad value collect2: ld returned 1 exit status
author Mark Doliner <mark@kingant.net>
date Wed, 12 Nov 2008 11:30:51 +0000
parents 41959f031322
children adf153852bcf
line wrap: on
line diff
--- a/libpurple/protocols/bonjour/Makefile.am	Wed Nov 12 09:40:05 2008 +0000
+++ b/libpurple/protocols/bonjour/Makefile.am	Wed Nov 12 11:30:51 2008 +0000
@@ -30,10 +30,10 @@
 if STATIC_BONJOUR
 
 st = -DPURPLE_STATIC_PRPL
-noinst_LIBRARIES     = libbonjour.a
-libbonjour_a_SOURCES = $(BONJOURSOURCES)
-libbonjour_a_CFLAGS  = $(AM_CFLAGS)
-libbonjour_a_LIBADD  = $(AVAHI_LIBS)
+noinst_LTLIBRARIES    = libbonjour.la
+libbonjour_la_SOURCES = $(BONJOURSOURCES)
+libbonjour_la_CFLAGS  = $(AM_CFLAGS)
+libbonjour_la_LIBADD  = $(AVAHI_LIBS)
 
 else
 
@@ -44,12 +44,10 @@
 
 endif
 
-
 AM_CPPFLAGS = \
 	-I$(top_srcdir)/libpurple \
 	-I$(top_builddir)/libpurple \
 	$(GLIB_CFLAGS) \
 	$(DEBUG_CFLAGS) \
 	$(LIBXML_CFLAGS) \
-	$(AVAHI_CFLAGS)
-
+	$(AVAHI_CFLAGS)
\ No newline at end of file