diff libpurple/protocols/yahoo/Makefile.am @ 24389:2b62300d2c19

Use libtool to build static archives when --with-static-prpls is passed to configure. Does anyone know why we weren't using libtool before? We were building old-fashioned .a files. But libtool archives (.la) can contain either static or shared libraries. I found it a lot easier to get static prpl compilation working after making this change (that is to say, it worked). Without this I got this error, which is probably fixable, but consistently using libtool seems like it makes things easier: *** Warning: Linking the shared library libpurple.la against the *** static library ../libpurple/protocols/msn/libmsn.a is not portable! /usr/bin/ld: ../libpurple/protocols/msn/libmsn.a(libmsn_a-msn.o): relocation R_X86_64_32 against `a local symbol' can not be used when making a shared object; recompile with -fPIC ../libpurple/protocols/msn/libmsn.a: could not read symbols: Bad value collect2: ld returned 1 exit status
author Mark Doliner <mark@kingant.net>
date Wed, 12 Nov 2008 11:30:51 +0000
parents c9aeb5a53d4d
children adf153852bcf 9656dbf35fb0
line wrap: on
line diff
--- a/libpurple/protocols/yahoo/Makefile.am	Wed Nov 12 09:40:05 2008 +0000
+++ b/libpurple/protocols/yahoo/Makefile.am	Wed Nov 12 11:30:51 2008 +0000
@@ -1,5 +1,5 @@
 EXTRA_DIST = \
-		Makefile.mingw
+	Makefile.mingw
 
 pkgdir = $(libdir)/purple-$(PURPLE_MAJOR_VERSION)
 
@@ -36,9 +36,9 @@
 if STATIC_YAHOO
 
 st = -DPURPLE_STATIC_PRPL
-noinst_LIBRARIES   = libyahoo.a
-libyahoo_a_SOURCES = $(YAHOOSOURCES)
-libyahoo_a_CFLAGS  = $(AM_CFLAGS)
+noinst_LTLIBRARIES  = libyahoo.la
+libyahoo_la_SOURCES = $(YAHOOSOURCES)
+libyahoo_la_CFLAGS  = $(AM_CFLAGS)
 
 else
 
@@ -53,4 +53,4 @@
 	-I$(top_srcdir)/libpurple \
 	-I$(top_builddir)/libpurple \
 	$(GLIB_CFLAGS) \
-	$(DEBUG_CFLAGS)
+	$(DEBUG_CFLAGS)
\ No newline at end of file