diff src/protocols/zephyr/Makefile.am @ 8378:2b68c423357e

[gaim-migrate @ 9105] " For people and systems which have libzephyr installed (e.g Debian), this will allow the zephyr plugin to optionally be linked against it, instead of building and linking in the libzephyr that comes with gaim. Why? 1) A gaim binary package can be compiled against a locally installed libzephyr.a, and use either unkerberized or kerberized zephyr depending on which version of the zephyr shared libraries is installed. 2) It reduces the build speed and size of the zephyr plugin (on Debian x86, from 6.5 MB to ~ 300 kb) Also, I added a zephyr icon (a blue Z), that's similar to the icons used by Windows and MacOS zephyr clients at MIT." --Arun A Tharuvai someone will have to tell me how to fix the win32 makefiles, and i'm not sure he patched enough to get his icon to be actually used. committer: Tailor Script <tailor@pidgin.im>
author Luke Schierer <lschiere@pidgin.im>
date Mon, 01 Mar 2004 18:08:42 +0000
parents 6b1ecf40f3ba
children 2cc05a9e944d
line wrap: on
line diff
--- a/src/protocols/zephyr/Makefile.am	Mon Mar 01 18:01:11 2004 +0000
+++ b/src/protocols/zephyr/Makefile.am	Mon Mar 01 18:08:42 2004 +0000
@@ -65,10 +65,14 @@
 	\
 	zephyr.c
 
+ZEPHYRSOURCESEXT = zephyr.c
+
 AM_CFLAGS = $(st)
 
 ZEPHYRLIBS = $(KRB4_LDFLAGS) $(KRB4_LIBS)
 
+ZEPHYRLIBSEXT = $(ZEPHYR_LDFLAGS) $(ZEPHYR_LIBS)
+
 libzephyr_la_LDFLAGS = -module -avoid-version
 
 if STATIC_ZEPHYR
@@ -83,8 +87,15 @@
 
 st = -Dlint
 pkg_LTLIBRARIES = libzephyr.la
+
+if EXTERNAL_LIBZEPHYR
+libzephyr_la_SOURCES = $(ZEPHYRSOURCESEXT)
+libzephyr_la_LIBADD = $(ZEPHYRLIBSEXT)
+else
 libzephyr_la_SOURCES = $(ZEPHYRSOURCES)
 libzephyr_la_LIBADD  = $(ZEPHYRLIBS)
+endif
+
 
 endif