diff configure.ac @ 30111:34af082d702e

Add a configure option --enable-trayicon-compat which installs tray icons into a directory compatible with older versions of hicolor-icon-theme. Use this option on distros that don't have a new enough copy. If you actually have a new enough copy, this option should not have any adverse effects. Fixes #11846.
author Elliott Sales de Andrade <qulogic@pidgin.im>
date Fri, 28 May 2010 06:14:35 +0000
parents 95d2b6fc228a
children 0a3490f24e2b
line wrap: on
line diff
--- a/configure.ac	Fri May 28 04:26:39 2010 +0000
+++ b/configure.ac	Fri May 28 06:14:35 2010 +0000
@@ -2467,6 +2467,13 @@
 AM_CONDITIONAL(INSTALL_PIXMAPS, test "x$enable_pixmaps" = "xyes")
 
 dnl #######################################################################
+dnl # Tweak status tray icon installation directory
+dnl #######################################################################
+AC_ARG_ENABLE(trayicon-compat, AC_HELP_STRING([--enable-trayicon-compat], [install tray icons in location compatible with older releases of hicolor-icon-theme]), enable_traycompat="$enableval", enable_traycompat=no)
+
+AM_CONDITIONAL(ENABLE_TRAYCOMPAT, test "x$enable_traycompat" = "xyes")
+
+dnl #######################################################################
 dnl # Check for Doxygen and dot (part of GraphViz)
 dnl #######################################################################
 AC_ARG_ENABLE(doxygen,
@@ -2635,6 +2642,7 @@
 echo Use external libzephyr........ : $zephyr
 echo Use external libgadu.......... : $gadu_libs
 echo Install pixmaps............... : $enable_pixmaps
+echo Old tray icon compatibility... : $enable_traycompat
 echo Install translations.......... : $enable_i18n
 echo Has you....................... : yes
 echo