diff configure.ac @ 10803:3595f818ee37

[gaim-migrate @ 12450] Use silcclient.pc (as included with SILC toolkit 0.9.13) if available, otherwise fallback to the silc.pc that distributions included with 0.9.12 committer: Tailor Script <tailor@pidgin.im>
author Stu Tomlinson <stu@nosnilmot.com>
date Sat, 09 Apr 2005 16:36:11 +0000
parents 7283a335cf23
children 364a2ef907ae
line wrap: on
line diff
--- a/configure.ac	Sat Apr 09 14:55:50 2005 +0000
+++ b/configure.ac	Sat Apr 09 16:36:11 2005 +0000
@@ -112,11 +112,19 @@
 	silc_manual_check="no"
 fi
 if test "x$silc_manual_check" = "xno"; then
-	PKG_CHECK_MODULES(SILC, silc, [
+	PKG_CHECK_MODULES(SILC, silcclient, [
 		have_silc="yes"
 		silcincludes="yes"
 		silcclient="yes"
 	], have_silc="no")
+	dnl If silcclient.pc wasn't found, check for just silc.pc
+	if test "x$have_silc" = "xno"; then
+		PKG_CHECK_MODULES(SILC, silc, [
+			have_silc="yes"
+			silcincludes="yes"
+			silcclient="yes"
+		], have_silc="no")
+	fi
 else
 	if test "$ac_silc_includes" != "no"; then
 		SILC_CFLAGS="-I$ac_silc_includes"