diff libpurple/Makefile.am @ 23330:390384053186

Add a configure option, --with-ssl-certificates to allow packagers to specify a system-wide SSL CA certificates directory. On Debian, this would be /etc/ssl/certs. Also, when set, we don't install our SSL CA certs. Refs #6036
author Richard Laager <rlaager@wiktel.com>
date Mon, 09 Jun 2008 02:10:18 +0000
parents 28a60a010efc
children 3da0957e7821 60d3ba8c9047
line wrap: on
line diff
--- a/libpurple/Makefile.am	Mon Jun 09 00:14:40 2008 +0000
+++ b/libpurple/Makefile.am	Mon Jun 09 02:10:18 2008 +0000
@@ -261,3 +261,9 @@
 	$(DBUS_CFLAGS) \
 	$(LIBXML_CFLAGS) \
 	$(NETWORKMANAGER_CFLAGS)
+
+# INSTALL_SSL_CERTIFICATES is true when SSL_CERTIFICATES_DIR is empty.
+# We want to use SSL_CERTIFICATES_DIR when it's not empty.
+if ! INSTALL_SSL_CERTIFICATES
+AM_CPPFLAGS += -DSSL_CERTIFICATES_DIR=\"$(SSL_CERTIFICATES_DIR)\"
+endif