diff configure.ac @ 12438:3ac0000247e9

[gaim-migrate @ 14745] Properly handle -Wall being set in the environment's CFLAGS. committer: Tailor Script <tailor@pidgin.im>
author Richard Laager <rlaager@wiktel.com>
date Fri, 09 Dec 2005 06:21:21 +0000
parents 8f98014a4e7d
children 799e95eed274
line wrap: on
line diff
--- a/configure.ac	Fri Dec 09 06:12:20 2005 +0000
+++ b/configure.ac	Fri Dec 09 06:21:21 2005 +0000
@@ -340,6 +340,11 @@
 
 	if test "x$GCC" = "xyes"; then
 
+		dnl We enable -Wall later, regardless of --enable-debug.
+		dnl If it's set after the warning CFLAGS in the compiler invocation, it counteracts the -Wno... flags.
+		dnl This leads to warnings we don't want.
+		CFLAGS=`echo $CFLAGS |$sedpath 's/-Wall//'`
+
 		dnl ENABLE WARNINGS SUPPORTED BY THE VERSION OF GCC IN USE
 		dnl
 		dnl Future Possibilities