diff libpurple/plugins/Makefile.am @ 15565:3b6ce2116f74

I had this brilliant idea to deal with join/part notices "intelligently". So here's a plugin... In chat rooms above the set size (default: 20 users), the join/part notices will be blocked, EXCEPT for people on your buddy list and people who have said something in the last X (default: 10) minutes.
author Richard Laager <rlaager@wiktel.com>
date Mon, 05 Feb 2007 05:38:09 +0000
parents e9c12873fae0
children 65b45106bfbb 2f6ea4cbcbb3
line wrap: on
line diff
--- a/libpurple/plugins/Makefile.am	Mon Feb 05 05:28:54 2007 +0000
+++ b/libpurple/plugins/Makefile.am	Mon Feb 05 05:38:09 2007 +0000
@@ -28,6 +28,7 @@
 autoreply_la_LDFLAGS        = -module -avoid-version
 buddynote_la_LDFLAGS        = -module -avoid-version
 idle_la_LDFLAGS             = -module -avoid-version
+joinpart_la_LDFLAGS         = -module -avoid-version
 log_reader_la_LDFLAGS       = -module -avoid-version
 newline_la_LDFLAGS          = -module -avoid-version
 offlinemsg_la_LDFLAGS       = -module -avoid-version
@@ -44,6 +45,7 @@
 	autoreply.la        \
 	buddynote.la        \
 	idle.la             \
+	joinpart.la         \
 	log_reader.la       \
 	newline.la          \
 	offlinemsg.la       \
@@ -55,6 +57,7 @@
 autoreply_la_SOURCES        = autoreply.c
 buddynote_la_SOURCES        = buddynote.c
 idle_la_SOURCES             = idle.c
+joinpart_la_SOURCES         = joinpart.c
 log_reader_la_SOURCES       = log_reader.c
 newline_la_SOURCES          = newline.c
 offlinemsg_la_SOURCES       = offlinemsg.c
@@ -65,6 +68,7 @@
 autoreply_la_LIBADD         = $(GLIB_LIBS)
 buddynote_la_LIBADD         = $(GLIB_LIBS)
 idle_la_LIBADD              = $(GLIB_LIBS)
+joinpart_la_LIBADD          = $(GLIB_LIBS)
 log_reader_la_LIBADD        = $(GLIB_LIBS)
 newline_la_LIBADD           = $(GLIB_LIBS)
 offlinemsg_la_LIBADD        = $(GLIB_LIBS)