diff configure.ac @ 2184:3bd61577ab8b

[gaim-migrate @ 2194] i wonder if this works better. committer: Tailor Script <tailor@pidgin.im>
author Eric Warmenhoven <eric@warmenhoven.org>
date Tue, 28 Aug 2001 18:44:13 +0000
parents 665e1dbeb8da
children 65d76d629d1b
line wrap: on
line diff
--- a/configure.ac	Tue Aug 28 18:17:32 2001 +0000
+++ b/configure.ac	Tue Aug 28 18:44:13 2001 +0000
@@ -227,7 +227,7 @@
         if test "$no_esd" != yes ; then
 		old_CFLAGS="$CFLAGS"
         	CFLAGS="$CFLAGS $ESD_CFLAGS"
-		AC_CHECK_HEADER(esd.h,
+		AC_TRY_COMPILE(,[#include <esd.h>],
 			[
 				AC_DEFINE(ESD_SOUND)
 				SOUND_LIBS="$SOUND_LIBS $ESD_LIBS"
@@ -244,7 +244,7 @@
 	if test "x$no_artsc" != "xyes" ; then
 		old_CFLAGS="$CFLAGS"
 		CFLAGS="$CFLAGS $ARTSC_CFLAGS"
-		AC_CHECK_HEADER(artsc.h,
+		AC_TRY_COMPILE(,[#include <artsc.h>],
 			[
 				AC_DEFINE(ARTSC_SOUND)
 				SOUND_LIBS="$SOUND_LIBS $ARTSC_LIBS"