diff configure.ac @ 21030:3cc856ca2338

Add a --with-extraversion option to ./configure so packagers can fine tune the version displayed to the end user to assist in support and things. Fixes #3681
author Stu Tomlinson <stu@nosnilmot.com>
date Sat, 27 Oct 2007 13:56:54 +0000
parents be41d3e89795
children 9347a942b7cd
line wrap: on
line diff
--- a/configure.ac	Sat Oct 27 13:36:14 2007 +0000
+++ b/configure.ac	Sat Oct 27 13:56:54 2007 +0000
@@ -283,6 +283,17 @@
 AC_SUBST(GLIB_CFLAGS)
 AC_SUBST(GLIB_LIBS)
 
+AC_ARG_WITH([extraversion],
+			AC_HELP_STRING([--with-extraversion=STRING],
+						   [extra version number to be displayed in Help->About and --help (for packagers)]),
+						   EXTRA_VERSION=$withval)
+
+if test x"$EXTRA_VERSION" != "x" ; then
+	AC_DEFINE_UNQUOTED(DISPLAY_VERSION, "$VERSION-$EXTRA_VERSION", [display version info])
+else
+	AC_DEFINE_UNQUOTED(DISPLAY_VERSION, "$VERSION", [display version info])
+fi
+
 AC_ARG_WITH(x, [],
 	with_x="$withval", with_x="yes")
 AC_ARG_ENABLE(gtkui, [AC_HELP_STRING([--disable-gtkui],