diff src/Makefile.am @ 3478:3da42b64304e

[gaim-migrate @ 3532] This isn't complete--but it's cool. gaim-remote is now built and installed. Eventually it will do lots of cool stuff--right now it just handles aim:// URI's. Try it out... when connected to OSCAR run: gaim-remote uri "aim://goim?screenname=seanegn&message=Good+job+Sean" Also, I made it so that if you're already running a Gaim session, and start a new one, it won't auto-login and disconnect all your accounts from the first instance. Useful if you accidentally hit the wrong button or something. committer: Tailor Script <tailor@pidgin.im>
author Sean Egan <seanegan@gmail.com>
date Fri, 30 Aug 2002 16:09:22 +0000
parents a4ec98a586fe
children 25eea0717f72
line wrap: on
line diff
--- a/src/Makefile.am	Fri Aug 30 03:39:00 2002 +0000
+++ b/src/Makefile.am	Fri Aug 30 16:09:22 2002 +0000
@@ -1,6 +1,6 @@
 SUBDIRS = protocols
 
-bin_PROGRAMS = gaim
+bin_PROGRAMS = gaim gaim-remote
 gaim_SOURCES =	about.c \
 		aim.c \
 		away.c \
@@ -25,12 +25,15 @@
 		proxy.c \
 		prpl.c \
 		server.c \
+		socket.c \
 		sound.c \
 		util.c
 gaim_DEPENDENCIES = @LIBOBJS@ $(STATIC_LINK_LIBS)
 gaim_LDFLAGS = -export-dynamic
 gaim_LDADD = @LDADD@ @LIBOBJS@
 
+gaim_remote_SOURCES = gaim-remote.c socket.c
+
 CFLAGS += $(PERL_CFLAGS)
 CFLAGS += -DLOCALEDIR=\"$(datadir)/locale\" -DLIBDIR=\"$(libdir)/gaim/\" $(DEBUG_CFLAGS) -DDATADIR=\"$(datadir)\"