diff Makefile.am @ 13490:40c5d0508a1a

[gaim-migrate @ 15866] This is a refactoring of the dbus service directory detection stuff. It was originally taken from guifications and that version had problem when a prefix was specificed to configure. Basically it would always try to install into the system directory regardless of --prefix. Anyways, this new code takes that into consideration. Also, I changed the way gaim.service is generated. It's now created from a .in file and has been relocated to the top of the source tree. committer: Tailor Script <tailor@pidgin.im>
author Gary Kramlich <grim@reaperworld.com>
date Sun, 12 Mar 2006 21:09:16 +0000
parents c87ab056417b
children 009db0b357b5
line wrap: on
line diff
--- a/Makefile.am	Sun Mar 12 01:15:54 2006 +0000
+++ b/Makefile.am	Sun Mar 12 21:09:16 2006 +0000
@@ -5,6 +5,7 @@
 		gaim.spec.in \
 		gaim.apspec.in \
 		gaim.desktop.in \
+		gaim.service.in \
 		gaim-installer.nsi \
 		HACKING \
 		intltool-extract.in \
@@ -31,6 +32,11 @@
 pkgconfigdir = $(libdir)/pkgconfig
 pkgconfig_DATA = gaim.pc
 
+if ENABLE_DBUS
+dbus_servicedir=$(DBUS_SERVICES_DIR)
+dbus_service_DATA=gaim.service
+endif
+
 dist-hook: gaim.spec
 	cp gaim.spec $(distdir)