diff configure.ac @ 11662:4117f696638e

[gaim-migrate @ 13947] A bunch of tweaks, mainly to fix the false positives during configure, and i'm still trying to make this not die with distcc... committer: Tailor Script <tailor@pidgin.im>
author Gary Kramlich <grim@reaperworld.com>
date Fri, 14 Oct 2005 05:58:39 +0000
parents a3302d271199
children ffc7d932178a
line wrap: on
line diff
--- a/configure.ac	Fri Oct 14 05:28:50 2005 +0000
+++ b/configure.ac	Fri Oct 14 05:58:39 2005 +0000
@@ -576,14 +576,14 @@
 dnl # Check for Mono support
 dnl #######################################################################
 
-if test "$enable_mono" = yes ; then
+if test x"$enable_mono" = x"yes" ; then
 	AC_MSG_CHECKING(for Mono compile flags)
 	MONO_CFLAGS=`pkg-config --cflags mono 2> /dev/null`
 	if test $? != 0 ; then
 		AC_MSG_RESULT([not found, building without mono.])
 		MONO_CFLAGS=
 		MONO_LIBS=
-		enable_mono = no
+		enable_mono=no
 	else
 		MONO_LIBS=`pkg-config --libs mono 2> /dev/null`
 		AC_MSG_RESULT(ok)
@@ -605,12 +605,12 @@
 else
 	MONO_CFLAGS=
 	MONO_LIBS=
-	enable_mono = no
+	enable_mono=no
 fi
 
 AC_SUBST(MONO_CFLAGS)
 AC_SUBST(MONO_LIBS)
-AM_CONDITIONAL(USE_MONO, test "x$enable_mono" = "xyes")
+AM_CONDITIONAL(USE_MONO, test x"$enable_mono" = x"yes")
 
 dnl #######################################################################
 dnl # Check for Perl support