diff src/protocols/napster/Makefile.am @ 2086:424a40f12a6c

[gaim-migrate @ 2096] moving protocols from plugins/ to src/protocols. making it so that you can select which protocols are compiled statically. committer: Tailor Script <tailor@pidgin.im>
author Eric Warmenhoven <eric@warmenhoven.org>
date Tue, 31 Jul 2001 01:00:39 +0000
parents
children 5486d558ecee
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/src/protocols/napster/Makefile.am	Tue Jul 31 01:00:39 2001 +0000
@@ -0,0 +1,21 @@
+pkgdir = $(libdir)/gaim
+
+CFLAGS += -I\$(top_srcdir)/src $(st) $(DEBUG_CFLAGS)
+
+if STATIC_NAPSTER
+
+st = -DSTATIC
+pkg_LTLIBRARIES =
+noinst_LIBRARIES = libnapster.a
+
+libnapster_a_SOURCES = napster.c
+
+else
+
+st =
+pkg_LTLIBRARIES = libnapster.la
+noinst_LIBRARIES =
+
+libnapster_la_SOURCES = napster.c
+
+endif