diff configure.in @ 1906:42aa9434800a

[gaim-migrate @ 1916] gah. committer: Tailor Script <tailor@pidgin.im>
author Eric Warmenhoven <eric@warmenhoven.org>
date Mon, 28 May 2001 20:37:58 +0000
parents 7af8b0fb931a
children e92b4bada176
line wrap: on
line diff
--- a/configure.in	Mon May 28 19:18:06 2001 +0000
+++ b/configure.in	Mon May 28 20:37:58 2001 +0000
@@ -21,7 +21,6 @@
 AC_HEADER_STDC
 AC_HEADER_SYS_WAIT
 AC_CHECK_HEADERS(fcntl.h sys/time.h unistd.h locale.h signal.h)
-AC_CHECK_HEADERS(pthread.h,,AC_MSG_ERROR([*** POSIX thread support not found ***]))
 
 dnl Checks for typedefs, structures, and compiler characteristics.
 AC_C_CONST
@@ -45,6 +44,7 @@
 AC_ARG_ENABLE(multi,   [  --disable-multi         disable multiple connections],,enable_multi=yes)
 AC_ARG_ENABLE(prpls,   [  --disable-prpls         don't build protocol plugins],,enable_prpls=yes)
 AC_ARG_ENABLE(gnome,   [  --disable-gnome         compile without Gnome bits],,enable_gnome=yes)
+AC_ARG_ENABLE(pixbuf,   [  --disable-pixbuf        compile without GdkPixbuf (needed for Buddy Icons)],,enable_pixbuf=yes)
 AC_ARG_ENABLE(panel,   [  --enable-panel          compile as a GNOME applet],,enable_panel=$enable_distrib)
 AM_CONDITIONAL(GNOMEAPPLET, test "x$enable_panel" = "xyes")
 AC_ARG_ENABLE(esd,     [  --disable-esd           Turn off ESD (default=auto)],,enable_esd=yes)
@@ -54,7 +54,6 @@
 AC_ARG_ENABLE(debug,   [  --enable-debug          compile with debugging support],,enable_debug=no)
 AC_ARG_ENABLE(screensaver,   [  --disable-screensaver   compile without X screensaver extension],,enable_xss=yes)
 AC_ARG_WITH(krb4,      [  --with-krb4=PREFIX      Compile Zephyr plugin with Kerberos 4 support],kerberos="$withval",kerberos="no")
-AC_ARG_ENABLE(,,,)
 
 if test "$enable_debug" = yes ; then
 	CFLAGS="$CFLAGS -Wall -g"
@@ -68,13 +67,12 @@
 		CFLAGS="$CFLAGS $GNOME_INCLUDEDIR"
 		AC_DEFINE(USE_APPLET)
 		AC_DEFINE(USE_GNOME)
-		GDK_PIXBUF_LIBS=`$GNOME_CONFIG --libs gdk_pixbuf`
-		LIBS="$LIBS $GTK_LIBS $GNOME_LIBDIR $GNOME_APPLETS_LIBS $GNOMEUI_LIBS $GDK_PIXBUF_LIBS"
+		LIBS="$LIBS $GTK_LIBS $GNOME_LIBDIR $GNOME_APPLETS_LIBS $GNOMEUI_LIBS"
 		AC_PATH_PROG(gaimpath, gaim_applet)
 	else
 		AC_PATH_PROG(gnomepath, gnome-config)
 		AC_MSG_CHECKING(for Gnome compile flags)
-		GNOME_CFLAGS=`$gnomepath gnomeui gdk_pixbuf --cflags 2>/dev/null`
+		GNOME_CFLAGS=`$gnomepath gnomeui --cflags 2>/dev/null`
 		if test "x$GNOME_CFLAGS" = "x" ; then
 			enable_gnome=no
 			AC_MSG_RESULT([Gnome not found, building without it.])
@@ -87,7 +85,7 @@
 			else
 				AC_MSG_RESULT(ok)
 				CFLAGS="$CFLAGS $GNOME_CFLAGS"
-				LIBS="$LIBS `$gnomepath gnomeui gdk_pixbuf --libs 2>/dev/null`"
+				LIBS="$LIBS `$gnomepath gnomeui --libs 2>/dev/null`"
 				AC_DEFINE(USE_GNOME)
 				GNOME_CONFIG="$gnomepath"
 				AC_SUBST(GNOME_CONFIG)
@@ -111,6 +109,24 @@
 fi
 CFLAGS="$CFLAGS $GTK_CFLAGS"
 
+use_pixbuf=no
+if test "x$enable_pixbuf" = "xyes" ; then
+	AC_PATH_PROG(pixbufcfg, gdk-pixbuf-config)
+	if test "x$pixbufcfg" != "x" ; then
+		GDK_PIXBUF_CFLAGS=`$pixbufcfg --cflags`
+		GDK_PIXBUF_LIBS=`$pixbufcfg --libs`
+		GDK_PIXBUF_CONFIG="$pixbufcfg"
+		AC_SUBST(GDK_PIXBUF_CONFIG)
+		AC_SUBST(GDK_PIXBUF_CFLAGS)
+		AC_SUBST(GDK_PIXBUF_LIBS)
+		CFLAGS="$CFLAGS $GDK_PIXBUF_CFLAGS"
+		LIBS="$LIBS $GDK_PIXBUF_LIBS"
+		dnl We should be doing checks to see that the header files and functions exist. eh.
+		AC_DEFINE(USE_PIXBUF)
+		use_pixbuf=yes
+	fi
+fi
+
 dnl Check for XScreenSaver
 if test "x$enable_xss" = "xyes" ; then
 	XSS_LIBS="no"
@@ -285,6 +301,7 @@
 echo Build Protocol Plugins..... : $enable_prpls
 echo
 echo Build with GNOME bits...... : $enable_gnome
+echo Use GdkPixbuf for Icons.... : $use_pixbuf
 echo Build as GNOME applet...... : $enable_panel
 echo
 echo Build with Plugin support.. : $enable_plugins