diff configure.ac @ 4581:4b1e24835bbf

[gaim-migrate @ 4864] put NAS sound support back in, and re-wrote a lot of the libao stuff this should mostly put an end to people having to make a ~/.libao file committer: Tailor Script <tailor@pidgin.im>
author Nathan Walp <nwalp@pidgin.im>
date Fri, 14 Feb 2003 20:57:32 +0000
parents 27354602734d
children 42d53c416bb9
line wrap: on
line diff
--- a/configure.ac	Wed Feb 12 17:16:16 2003 +0000
+++ b/configure.ac	Fri Feb 14 20:57:32 2003 +0000
@@ -123,6 +123,7 @@
 	[Loads static protocol plugin module initialization functions.])
 
 AC_ARG_ENABLE(audio,   [  --disable-audio         compile without libao/libaudiofile for sound playing],,enable_audio=yes)
+AC_ARG_ENABLE(nas,     [  --enable-nas            enable NAS (Network Audio System) support],,enable_nas=no)
 AC_ARG_ENABLE(plugins, [  --disable-plugins       compile without plugin support],,enable_plugins=yes)
 AC_ARG_ENABLE(perl,    [  --disable-perl          compile without perl scripting],,enable_perl=yes)
 AC_ARG_ENABLE(gtkspell, [  --disable-gtkspell      compile without GtkSpell automatic spell checking],,enable_gtkspell=yes)
@@ -271,13 +272,18 @@
 	fi
 fi
 
+if test "$enable_nas" = yes ; then
+	AC_DEFINE(USE_NAS_AUDIO, 1, [Define if we have NAS sound support.])
+	SOUND_LIBS="$SOUND_LIBS -laudio -lXt"
+fi
+
 if test "$enable_audio" = yes ; then
 	GAIM_PATH_AO(found_ao_lib=true)
 
 	AM_PATH_AUDIOFILE([0.2.0], found_af_lib=true)
 
 	if test "$found_ao_lib" = "true" -a "$found_af_lib" = "true"; then
-		SOUND_LIBS="$AO_LIBS $AUDIOFILE_LIBS"
+		SOUND_LIBS="$SOUND_LIBS $AO_LIBS $AUDIOFILE_LIBS"
 		AC_SUBST(SOUND_LIBS)
 		AC_DEFINE(USE_AO, 1, [Define if we're using libao and libaudiofile for sound playing])
 		enable_audio=yes
@@ -421,6 +427,7 @@
 echo Build with Plugin support..... : $enable_plugins
 echo Build with Perl support....... : $enable_perl
 echo Build with Audio support...... : $enable_audio
+echo Build with NAS support........ : $enable_nas
 echo Build with GtkSpell support... : $enable_gtkspell
 echo
 echo Use XScreenSaver Extension.... : $enable_xss