diff libpurple/tests/Makefile.am @ 28788:5152c6cea318

Make sure libpurple libraries are the first thing in the test suite's library path. Maybe the newer libtool's don't leave out the system library path when constructing this now, but if the system path is first, running the tests will load the system version of libpurple instead of the just built copy. Fixes #10966.
author Elliott Sales de Andrade <qulogic@pidgin.im>
date Sun, 13 Dec 2009 02:27:48 +0000
parents 338eeaf371e2
children 485f69e04d6a
line wrap: on
line diff
--- a/libpurple/tests/Makefile.am	Sun Dec 13 00:36:36 2009 +0000
+++ b/libpurple/tests/Makefile.am	Sun Dec 13 02:27:48 2009 +0000
@@ -27,11 +27,11 @@
 		-DBUILDDIR=\"$(top_builddir)\"
 
 check_libpurple_LDADD=\
-        @CHECK_LIBS@ \
-		$(GLIB_LIBS) \
 		$(top_builddir)/libpurple/protocols/jabber/libjabber.la \
 		$(top_builddir)/libpurple/protocols/qq/libqq.la \
 		$(top_builddir)/libpurple/protocols/yahoo/libymsg.la \
-		$(top_builddir)/libpurple/libpurple.la
+		$(top_builddir)/libpurple/libpurple.la \
+        @CHECK_LIBS@ \
+		$(GLIB_LIBS)
 
 endif