diff plugins/Makefile.am @ 4202:59751fe608c5

[gaim-migrate @ 4438] Much needed Makefile.am cleanups. Sorry for the large mass of commit e-mails, everyone. These changes should work on older versions of automake and newer versions. If you do have a problem, let me know, but it should be a smooth transition. committer: Tailor Script <tailor@pidgin.im>
author Christian Hammond <chipx86@chipx86.com>
date Sun, 05 Jan 2003 03:02:55 +0000
parents 1fb22bf10b4f
children 16540914c963
line wrap: on
line diff
--- a/plugins/Makefile.am	Sat Jan 04 21:01:32 2003 +0000
+++ b/plugins/Makefile.am	Sun Jan 05 03:02:55 2003 +0000
@@ -1,32 +1,62 @@
 SUBDIRS = docklet ticker
 
-CFLAGS += -I\$(top_srcdir) -I\$(top_srcdir)/src -DVERSION=\"$(VERSION)\"
+plugindir = $(libdir)/gaim
+
+#CFLAGS += -I\$(top_srcdir) -I\$(top_srcdir)/src -DVERSION=\"$(VERSION)\" $(DEBUG_CFLAGS)
+
+
+autorecon_la_LDFLAGS = -module -avoid-version
+chatlist_la_LDFLAGS  = -module -avoid-version
+iconaway_la_LDFLAGS  = -module -avoid-version
+notify_la_LDFLAGS    = -module -avoid-version
+spellchk_la_LDFLAGS  = -module -avoid-version
+history_la_LDFLAGS   = -module -avoid-version
+timestamp_la_LDFLAGS = -module -avoid-version
+idle_la_LDFLAGS      = -module -avoid-version
+
+if PLUGINS
+
+plugin_LTLIBRARIES = \
+	autorecon.la   \
+	chatlist.la    \
+	iconaway.la    \
+	notify.la      \
+	spellchk.la    \
+	history.la     \
+	timestamp.la   \
+	idle.la
+
+autorecon_la_SOURCES = autorecon.c
+chatlist_la_SOURCES  = chatlist.c
+iconaway_la_SOURCES  = iconaway.c
+notify_la_SOURCES    = notify.c
+spellchk_la_SOURCES  = spellchk.c
+history_la_SOURCES   = history.c
+timestamp_la_SOURCES = timestamp.c
+idle_la_SOURCES      = idle.c
+
+endif
+
+EXTRA_DIST = \
+	ChangeLog PERL-HOWTO HOWTO SIGNALS \
+	filectl.c mailchk.c gtik.c error.c \
+	gaim.pl fortuneprofile.pl
+
+AM_CPPFLAGS = \
+	-I$(top_srcdir)/src \
+	-DVERSION=\"$(VERSION)\" \
+	$(DEBUG_CFLAGS) \
+	$(PLUGIN_CFLAGS)
+
+#
+# This part allows people to build their own plugins in here.
+# Yes, it's a mess.
+#
 SUFFIXES = .c .so
 .c.so:
-	$(LIBTOOL) --mode=compile $(CC) $(CFLAGS) -c $< -o tmp$@.lo $(PLUGIN_CFLAGS)
+	$(LIBTOOL) --mode=compile $(CC) $(AM_CPPFLAGS) $(CFLAGS) -c $< -o tmp$@.lo $(PLUGIN_CFLAGS)
 	$(LIBTOOL) --mode=link    $(CC) $(CFLAGS) -o libtmp$@.la -rpath $(plugindir) tmp$@.lo $(LIBS) $(LDFLAGS) -module -avoid-version $(PLUGIN_LIBS)
 	@rm -f tmp$@.lo tmp$@.o libtmp$@.la
 	@cp .libs/libtmp$@.so* $@
 	@rm -f .libs/libtmp$@.*
 
-if PLUGINS
-
-plugindir = $(libdir)/gaim
-
-plugin_DATA = autorecon.so chatlist.so iconaway.so notify.so spellchk.so history.so timestamp.so idle.so
-
-$(plugin_DATA): $(top_srcdir)/src/gaim.h
-
-clean distclean:
-	rm -rf $(plugin_DATA) .libs
-
-else
-
-plugin_DATA = 
-
-endif
-
-
-EXTRA_DIST = ChangeLog PERL-HOWTO HOWTO SIGNALS autorecon.c filectl.c iconaway.c \
-		notify.c spellchk.c gaim.pl mailchk.c chatlist.c gtik.c error.c  \
-		history.c timestamp.c fortuneprofile.pl idle.c