diff src/protocols/gg/Makefile.am @ 4202:59751fe608c5

[gaim-migrate @ 4438] Much needed Makefile.am cleanups. Sorry for the large mass of commit e-mails, everyone. These changes should work on older versions of automake and newer versions. If you do have a problem, let me know, but it should be a smooth transition. committer: Tailor Script <tailor@pidgin.im>
author Christian Hammond <chipx86@chipx86.com>
date Sun, 05 Jan 2003 03:02:55 +0000
parents a5c49e9c6a53
children fcc28f5dd0c8
line wrap: on
line diff
--- a/src/protocols/gg/Makefile.am	Sat Jan 04 21:01:32 2003 +0000
+++ b/src/protocols/gg/Makefile.am	Sun Jan 05 03:02:55 2003 +0000
@@ -2,31 +2,33 @@
 
 pkgdir = $(libdir)/gaim
 
-CFLAGS += -I\$(top_srcdir)/src $(st) $(DEBUG_CFLAGS)
+GGSOURCES = \
+	libgg.c \
+	libgg.h \
+	common.c \
+	gg.c
+
+AM_CFLAGS = $(st)
+
 libgg_la_LDFLAGS = -module -avoid-version
 
 if STATIC_GG
 
 st = -DSTATIC
-pkg_LTLIBRARIES =
 noinst_LIBRARIES = libgg.a
 
-libgg_a_SOURCES = libgg.c \
-		  libgg.h \
-		  common.c \
-		  gg.c
-
-libgg_a_CFLAGS = $(AM_CFLAGS)
+libgg_a_SOURCES = $(GGSOURCES)
+libgg_a_CFLAGS  = $(AM_CFLAGS)
 
 else
 
 st =
 pkg_LTLIBRARIES = libgg.la
-noinst_LIBRARIES =
 
-libgg_la_SOURCES = libgg.c \
-		   libgg.h \
-		   common.c \
-		   gg.c
+libgg_la_SOURCES = $(GGSOURCES)
 
 endif
+
+AM_CPPFLAGS = \
+	-I$(top_srcdir)/src \
+	$(DEBUG_CFLAGS)