diff src/protocols/irc/Makefile.am @ 4202:59751fe608c5

[gaim-migrate @ 4438] Much needed Makefile.am cleanups. Sorry for the large mass of commit e-mails, everyone. These changes should work on older versions of automake and newer versions. If you do have a problem, let me know, but it should be a smooth transition. committer: Tailor Script <tailor@pidgin.im>
author Christian Hammond <chipx86@chipx86.com>
date Sun, 05 Jan 2003 03:02:55 +0000
parents 5df423e0bca8
children fcc28f5dd0c8
line wrap: on
line diff
--- a/src/protocols/irc/Makefile.am	Sat Jan 04 21:01:32 2003 +0000
+++ b/src/protocols/irc/Makefile.am	Sun Jan 05 03:02:55 2003 +0000
@@ -2,18 +2,20 @@
 
 pkgdir = $(libdir)/gaim
 
-CFLAGS += -I\$(top_srcdir)/src $(st) $(DEBUG_CFLAGS)
+IRCSOURCES = irc.c
+
+AM_CFLAGS = $(st)
+
 libirc_la_LDFLAGS = -module -avoid-version
 
 if STATIC_IRC
 
 st = -DSTATIC
+noinst_LIBRARIES = libirc.a
 pkg_LTLIBRARIES =
-noinst_LIBRARIES = libirc.a
 
-libirc_a_SOURCES = irc.c
-
-libirc_a_CFLAGS = $(AM_CFLAGS)
+libirc_a_SOURCES = $(IRCSOURCES)
+libirc_a_CFLAGS  = $(AM_CFLAGS)
 
 else
 
@@ -21,6 +23,10 @@
 pkg_LTLIBRARIES = libirc.la
 noinst_LIBRARIES =
 
-libirc_la_SOURCES = irc.c
+libirc_la_SOURCES = $(IRCSOURCES)
 
 endif
+
+AM_CPPFLAGS = \
+	-I$(top_srcdir)/src \
+	$(DEBUG_CFLAGS)