diff src/protocols/jabber/Makefile.am @ 4202:59751fe608c5

[gaim-migrate @ 4438] Much needed Makefile.am cleanups. Sorry for the large mass of commit e-mails, everyone. These changes should work on older versions of automake and newer versions. If you do have a problem, let me know, but it should be a smooth transition. committer: Tailor Script <tailor@pidgin.im>
author Christian Hammond <chipx86@chipx86.com>
date Sun, 05 Jan 2003 03:02:55 +0000
parents 5df423e0bca8
children fcc28f5dd0c8
line wrap: on
line diff
--- a/src/protocols/jabber/Makefile.am	Sat Jan 04 21:01:32 2003 +0000
+++ b/src/protocols/jabber/Makefile.am	Sun Jan 05 03:02:55 2003 +0000
@@ -2,16 +2,7 @@
 
 pkgdir = $(libdir)/gaim
 
-CFLAGS += -I\$(top_srcdir)/src $(st) $(DEBUG_CFLAGS)
-libjabber_la_LDFLAGS = 	-module -avoid-version
-
-if STATIC_JABBER
-
-st = -DSTATIC
-pkg_LTLIBRARIES =
-noinst_LIBRARIES = libjabber.a
-
-libjabber_a_SOURCES = \
+JABBERSOURCES = \
 			asciitab.h \
 			expat.c \
 			genhash.c \
@@ -53,54 +44,27 @@
 			\
 			jabber.c
 
+AM_CFLAGS = $(st)
+
+libjabber_la_LDFLAGS = -module -avoid-version
+
+if STATIC_JABBER
+
+st = -DSTATIC
+noinst_LIBRARIES = libjabber.a
+
+libjabber_a_SOURCES = $(JABBERSOURCES)
 libjabber_a_CFLAGS = $(AM_CFLAGS)
 
 else
 
 st =
 pkg_LTLIBRARIES = libjabber.la
-noinst_LIBRARIES =
 
-libjabber_la_SOURCES = \
-			asciitab.h \
-			expat.c \
-			genhash.c \
-			hashtable.c \
-			hashtable.h \
-			iasciitab.h \
-			karma.c \
-			latin1tab.h \
-			lib.h \
-			libxode.h \
-			nametab.h \
-			pool.c \
-			sha.c \
-			snprintf.c \
-			socket.c \
-			str.c \
-			utf8tab.h \
-			xhash.c \
-			xmldef.h \
-			xmlnode.c \
-			xmlparse.c \
-			xmlparse.h \
-			xmlrole.c \
-			xmlrole.h \
-			xmltok.c \
-			xmltok.h \
-			xmltok_impl.h \
-			xstream.c \
-			\
-			jabber.h \
-			jconn.c \
-			jid.c \
-			jpacket.c \
-			jutil.c \
-			log.c \
-			log.h \
-			pproxy.c \
-			rate.c \
-			\
-			jabber.c
+libjabber_la_SOURCES = $(JABBERSOURCES)
 
 endif
+
+AM_CPPFLAGS = \
+	-I$(top_srcdir)/src \
+	$(DEBUG_CFLAGS)