diff src/protocols/msn/Makefile.am @ 4202:59751fe608c5

[gaim-migrate @ 4438] Much needed Makefile.am cleanups. Sorry for the large mass of commit e-mails, everyone. These changes should work on older versions of automake and newer versions. If you do have a problem, let me know, but it should be a smooth transition. committer: Tailor Script <tailor@pidgin.im>
author Christian Hammond <chipx86@chipx86.com>
date Sun, 05 Jan 2003 03:02:55 +0000
parents 5df423e0bca8
children 86b0a0243be8
line wrap: on
line diff
--- a/src/protocols/msn/Makefile.am	Sat Jan 04 21:01:32 2003 +0000
+++ b/src/protocols/msn/Makefile.am	Sun Jan 05 03:02:55 2003 +0000
@@ -2,25 +2,27 @@
 
 pkgdir = $(libdir)/gaim
 
-CFLAGS += -I\$(top_srcdir)/src $(st) $(DEBUG_CFLAGS)
+MSNSOURCES = msn.c
+
+AM_CFLAGS = $(st)
+
 libmsn_la_LDFLAGS = -module -avoid-version
 
 if STATIC_MSN
 
 st = -DSTATIC
-pkg_LTLIBRARIES =
 noinst_LIBRARIES = libmsn.a
-
-libmsn_a_SOURCES = msn.c
-
-libmsn_a_CFLAGS = $(AM_CFLAGS)
+libmsn_a_SOURCES = $(MSNSOURCES)
+libmsn_a_CFLAGS  = $(AM_CFLAGS)
 
 else
 
 st =
-pkg_LTLIBRARIES = libmsn.la
-noinst_LIBRARIES =
-
-libmsn_la_SOURCES = msn.c
+pkg_LTLIBRARIES   = libmsn.la
+libmsn_la_SOURCES = $(MSNSOURCES)
 
 endif
+
+AM_CPPFLAGS = \
+	-I$(top_srcdir)/src \
+	$(DEBUG_CFLAGS)