diff src/protocols/oscar/Makefile.am @ 4202:59751fe608c5

[gaim-migrate @ 4438] Much needed Makefile.am cleanups. Sorry for the large mass of commit e-mails, everyone. These changes should work on older versions of automake and newer versions. If you do have a problem, let me know, but it should be a smooth transition. committer: Tailor Script <tailor@pidgin.im>
author Christian Hammond <chipx86@chipx86.com>
date Sun, 05 Jan 2003 03:02:55 +0000
parents 422512cf6488
children 2a2d6d21f1d7
line wrap: on
line diff
--- a/src/protocols/oscar/Makefile.am	Sat Jan 04 21:01:32 2003 +0000
+++ b/src/protocols/oscar/Makefile.am	Sun Jan 05 03:02:55 2003 +0000
@@ -1,93 +1,70 @@
-EXTRA_DIST = aim.h aim_cbtypes.h aim_internal.h faimconfig.h md5.h README \
-		CHANGES COPYING BUGS AUTHORS
+EXTRA_DIST = README CHANGES COPYING BUGS AUTHORS
 
 pkgdir = $(libdir)/gaim
 
+OSCARSOURCES = \
+	admin.c        \
+	adverts.c      \
+	aim.h          \
+	aim_cbtypes.h  \
+	aim_internal.h \
+	auth.c         \
+	bos.c          \
+	bstream.c      \
+	buddylist.c    \
+	chat.c         \
+	chatnav.c      \
+	conn.c         \
+	email.c        \
+	faimconfig.h   \
+	ft.c           \
+	icq.c          \
+	im.c           \
+	info.c         \
+	invite.c       \
+	md5.h          \
+	meta.c         \
+	misc.c         \
+	msgcookie.c    \
+	newsearch.c    \
+	popups.c       \
+	rxhandlers.c   \
+	rxqueue.c      \
+	search.c       \
+	service.c      \
+	snac.c         \
+	ssi.c          \
+	stats.c        \
+	tlv.c          \
+	translate.c    \
+	txqueue.c      \
+	util.c         \
+	oscar.c
+
 CURRENT_DATE := $(shell date +%Y%m%d)
 CURRENT_TIME := $(shell date +%H%M%S)
 
-CFLAGS += -DAIM_BUILDDATE=\"$(CURRENT_DATE)\" -DAIM_BUILDTIME=\"$(CURRENT_TIME)\" -I\$(top_srcdir)/src $(st) 
-$(DEBUG_CFLAGS)
-liboscar_la_LDFLAGS =	-module -avoid-version
+AM_CFLAGS = $(st)
+
+liboscar_la_LDFLAGS = -module -avoid-version
 
 if STATIC_OSCAR
 
 st = -DSTATIC
-pkg_LTLIBRARIES =
-noinst_LIBRARIES = liboscar.a
-
-liboscar_a_SOURCES = 	admin.c		\
-			adverts.c	\
-			auth.c 		\
-			bos.c 		\
-			bstream.c 	\
-			buddylist.c	\
-			chat.c		\
-			chatnav.c	\
-			conn.c		\
-			email.c		\
-			ft.c		\
-			icq.c		\
-			im.c		\
-			info.c		\
-			invite.c	\
-			meta.c		\
-			misc.c		\
-			msgcookie.c	\
-			newsearch.c	\
-			popups.c	\
-			rxhandlers.c	\
-			rxqueue.c	\
-			search.c	\
-			service.c	\
-			snac.c		\
-			ssi.c		\
-			stats.c		\
-			tlv.c		\
-			translate.c	\
-			txqueue.c	\
-			util.c		\
-			oscar.c
-
-liboscar_a_CFLAGS = $(AM_CFLAGS)
+noinst_LIBRARIES   = liboscar.a
+liboscar_a_SOURCES = $(OSCARSOURCES)
+liboscar_a_CFLAGS  = $(AM_CFLAGS)
 
 else
 
 st =
-pkg_LTLIBRARIES = liboscar.la
-noinst_LIBRARIES =
-
-liboscar_la_SOURCES = 	admin.c		\
-			adverts.c	\
-			auth.c 		\
-			bos.c 		\
-			bstream.c 	\
-			buddylist.c	\
-			chat.c		\
-			chatnav.c	\
-			conn.c		\
-			email.c		\
-			ft.c		\
-			icq.c		\
-			im.c		\
-			info.c		\
-			invite.c	\
-			meta.c		\
-			misc.c		\
-			msgcookie.c	\
-			newsearch.c	\
-			popups.c	\
-			rxhandlers.c	\
-			rxqueue.c	\
-			search.c	\
-			service.c	\
-			snac.c		\
-			ssi.c		\
-			stats.c		\
-			tlv.c		\
-			translate.c	\
-			txqueue.c	\
-			util.c		\
-			oscar.c
+pkg_LTLIBRARIES     = liboscar.la
+liboscar_la_SOURCES = $(OSCARSOURCES)
 
 endif
+
+AM_CPPFLAGS = \
+	-I$(top_srcdir)/src \
+	$(DEBUG_CFLAGS) \
+	-DAIM_BUILDDATE=\"$(CURRENT_DATE)\" \
+	-DAIM_BUILDTIME=\"$(CURRENT_TIME)\"