diff src/protocols/yahoo/Makefile.am @ 4202:59751fe608c5

[gaim-migrate @ 4438] Much needed Makefile.am cleanups. Sorry for the large mass of commit e-mails, everyone. These changes should work on older versions of automake and newer versions. If you do have a problem, let me know, but it should be a smooth transition. committer: Tailor Script <tailor@pidgin.im>
author Christian Hammond <chipx86@chipx86.com>
date Sun, 05 Jan 2003 03:02:55 +0000
parents 5df423e0bca8
children fcc28f5dd0c8
line wrap: on
line diff
--- a/src/protocols/yahoo/Makefile.am	Sat Jan 04 21:01:32 2003 +0000
+++ b/src/protocols/yahoo/Makefile.am	Sun Jan 05 03:02:55 2003 +0000
@@ -1,26 +1,29 @@
-EXTRA_DIST = md5.h
-
 pkgdir = $(libdir)/gaim
 
-CFLAGS += -I\$(top_srcdir)/src $(st) $(DEBUG_CFLAGS)
+YAHOOSOURCES = \
+	crypt.c \
+	md5.h \
+	yahoo.c
+
+AM_CFLAGS = $(st)
+
 libyahoo_la_LDFLAGS = -module -avoid-version
 
 if STATIC_YAHOO
 
 st = -DSTATIC
-pkg_LTLIBRARIES =
-noinst_LIBRARIES = libyahoo.a
-
-libyahoo_a_SOURCES = crypt.c yahoo.c
-
-libyahoo_a_CFLAGS = $(AM_CFLAGS)
+noinst_LIBRARIES   = libyahoo.a
+libyahoo_a_SOURCES = $(YAHOOSOURCES)
+libyahoo_a_CFLAGS  = $(AM_CFLAGS)
 
 else
 
 st =
-pkg_LTLIBRARIES = libyahoo.la
-noinst_LIBRARIES =
-
-libyahoo_la_SOURCES = crypt.c yahoo.c
+pkg_LTLIBRARIES     = libyahoo.la
+libyahoo_la_SOURCES = $(YAHOOSOURCES)
 
 endif
+
+AM_CPPFLAGS = \
+	-I$(top_srcdir)/src \
+	$(DEBUG_CFLAGS)