diff configure.ac @ 22495:5c216e2c5405

Revert the dependency on gstreamer-0.10 >= 0.10.10, falling back to the SIGALRM hack on gstreamers which can't disable forking. This should keep both Alver and Stu happy in their respective stone-ages.
author Will Thompson <will.thompson@collabora.co.uk>
date Mon, 17 Mar 2008 13:38:34 +0000
parents 14c476bcdaee
children 4bcd3868a136 e4a4bc86c547
line wrap: on
line diff
--- a/configure.ac	Mon Mar 17 06:14:38 2008 +0000
+++ b/configure.ac	Mon Mar 17 13:38:34 2008 +0000
@@ -658,14 +658,21 @@
 dnl #######################################################################
 dnl # Check for GStreamer
 dnl #######################################################################
+dnl
+dnl TODO: Depend on gstreamer >= 0.10.10, and remove the conditional use of
+dnl       gst_registry_fork_set_enabled.
 AC_ARG_ENABLE(gstreamer,
 	[AC_HELP_STRING([--disable-gstreamer], [compile without GStreamer audio support])],
 	enable_gst="$enableval", enable_gst="yes")
 if test "x$enable_gst" != "xno"; then
-	PKG_CHECK_MODULES(GSTREAMER, [gstreamer-0.10 >= 0.10.10], [
+	PKG_CHECK_MODULES(GSTREAMER, [gstreamer-0.10], [
 		AC_DEFINE(USE_GSTREAMER, 1, [Use GStreamer for playing sounds])
 		AC_SUBST(GSTREAMER_CFLAGS)
 		AC_SUBST(GSTREAMER_LIBS)
+		AC_CHECK_LIB(gstreamer-0.10, gst_registry_fork_set_enabled,
+			[ AC_DEFINE(GST_CAN_DISABLE_FORKING, [],
+			  [Define if gst_registry_fork_set_enabled exists])],
+			[], [$GSTREAMER_LIBS])
 	], [
 		AC_MSG_RESULT(no)
 		enable_gst="no"