diff pixmaps/Makefile.am @ 4359:5fb47ec9bfe4

[gaim-migrate @ 4625] Wow, okay, where to begin with this one ;) I rewrote the whole conversation backend. It is now core/UI split. Here's how it works.. Every conversation is represented by a gaim_conversation structure. This branches out into gaim_im and gaim_chat structures. Every conversation lives in (well, normally, but it doesn't have to) a gaim_window structure. This is a _CORE_ representation of a window. There can be multiple gaim_window structures around. The gaim_window and gaim_conversation structures have UI-specific operation structures associated with them. At the moment, the only UI is GTK+, and this will be for some time. Don't start thinking you can write a QT UI now. It's just not going to happen. Everything that is done on a conversation is done through the core API. This API does core processing and then calls the UI operations for the rendering and anything else. Now, what does this give the user? - Multiple windows. - Multiple tabs per window. - Draggable tabs. - Send As menu is moved to the menubar. - Menubar for chats. - Some very cool stuff in the future, like replacing, say, IRC chat windows with an X-Chat interface, or whatever. - Later on, customizable window/conversation positioning. For developers: - Fully documented API - Core/UI split - Variable checking and mostly sane handling of incorrect variables. - Logical structure to conversations, both core and UI. - Some very cool stuff in the future, like replacing, say, IRC chat windows with an X-Chat interface, or whatever. - Later on, customizable window/conversation positioning. - Oh yeah, and the beginning of a stock icon system. Now, there are things that aren't there yet. You will see tabs even if you have them turned off. This will be fixed in time. Also, the preferences will change to work with the new structure. I'm starting school in 2 days, so it may not be done immediately, but hopefully in the next week. Enjoy! committer: Tailor Script <tailor@pidgin.im>
author Christian Hammond <chipx86@chipx86.com>
date Mon, 20 Jan 2003 09:10:23 +0000
parents e03fc09a811a
children 109948475ecc
line wrap: on
line diff
--- a/pixmaps/Makefile.am	Mon Jan 20 07:00:10 2003 +0000
+++ b/pixmaps/Makefile.am	Mon Jan 20 09:10:23 2003 +0000
@@ -50,6 +50,10 @@
 		status-game.xpm			\
 		status-here.xpm			\
 		status-idle.xpm			\
+		tb_drag_arrow_down.xpm  \
+		tb_drag_arrow_left.xpm  \
+		tb_drag_arrow_right.xpm \
+		tb_drag_arrow_up.xpm    \
 		tb_forward.xpm			\
 		tb_redo.xpm			\
 		tb_refresh.xpm			\
@@ -72,7 +76,7 @@
 gaimmenupix_DATA = insert-image-small.png about_menu.png import-menu.png accounts-menu.png insert-link-small.png
 
 gaimdistpixdir = $(datadir)/pixmaps/gaim
-gaimdistpix_DATA = away.png connect.png msgpend.png offline.png online.png msgunread.png logo.png
+gaimdistpix_DATA = away.png connect.png msgpend.png offline.png online.png msgunread.png logo.png tb_drag_arrow_down.xpm tb_drag_arrow_left.xpm tb_drag_arrow_right.xpm tb_drag_arrow_up.xpm
 
 distpixmapdir = $(datadir)/pixmaps
 distpixmap_DATA = gaim.png