diff libpurple/plugins/tcl/Makefile.am @ 15373:5fe8042783c1

Rename gtk/ and libgaim/ to pidgin/ and libpurple/
author Sean Egan <seanegan@gmail.com>
date Sat, 20 Jan 2007 02:32:10 +0000
parents
children e9c12873fae0
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/libpurple/plugins/tcl/Makefile.am	Sat Jan 20 02:32:10 2007 +0000
@@ -0,0 +1,22 @@
+plugindir = $(libdir)/gaim
+
+tcl_la_LDFLAGS = -module -avoid-version
+
+plugin_LTLIBRARIES = tcl.la
+
+tcl_la_SOURCES = tcl.c tcl_glib.c tcl_glib.h tcl_cmds.c tcl_signals.c tcl_gaim.h \
+                 tcl_ref.c tcl_cmd.c
+
+tcl_la_LIBADD = $(GLIB_LIBS) $(TCL_LIBS) $(TK_LIBS)
+
+EXTRA_DIST = signal-test.tcl Makefile.mingw
+
+AM_CPPFLAGS = \
+	-DVERSION=\"$(VERSION)\" \
+	-I$(top_srcdir) \
+	-I$(top_srcdir)/libpurple \
+	$(DEBUG_CFLAGS) \
+	$(GLIB_CFLAGS) \
+	$(PLUGIN_CFLAGS) \
+	$(TK_CFLAGS) \
+	$(TCL_CFLAGS)