diff configure.ac @ 7155:6448e0163d7b

[gaim-migrate @ 7722] Now we support building with both GNUTLS and NSS at the same time. Yay! committer: Tailor Script <tailor@pidgin.im>
author Christian Hammond <chipx86@chipx86.com>
date Sun, 05 Oct 2003 05:03:38 +0000
parents bbf7f4604140
children 282887c9e3dc
line wrap: on
line diff
--- a/configure.ac	Sun Oct 05 01:25:01 2003 +0000
+++ b/configure.ac	Sun Oct 05 05:03:38 2003 +0000
@@ -428,7 +428,7 @@
 		if test "x$gnutls_libs" != "xno"; then
 			AC_DEFINE(HAVE_GNUTLS, 1, [Define if you have GNUTLS])
 			AC_DEFINE(HAVE_SSL)
-			msg_ssl="GNUTLS"
+			msg_gnutls="GNUTLS"
 			GNUTLS_LIBS="$with_gnutls_libs -lgnutls -lgcrypt"
 
 			enable_gnutls="yes"
@@ -454,7 +454,7 @@
 dnl #
 dnl # Check for NSS if it's specified, or if GNUTLS checks failed.
 dnl #
-if test "x$enable_nss" != "xno" -a "x$enable_gnutls" = "xno"; then
+if test "x$enable_nss" != "xno"; then
 
 	AC_ARG_WITH(nspr-includes,
 		[  --with-nspr-includes=PREFIX     Specify location of Mozilla nspr4 includes.],
@@ -494,7 +494,7 @@
 			AC_DEFINE(HAVE_NSS, 1, [Define if you have Mozilla NSS])
 			AC_DEFINE(HAVE_SSL, 1, [Define if you have SSL])
 
-			msg_ssl="Mozilla NSS"
+			msg_nss="Mozilla NSS"
 			enable_nss="yes"
 		else
 			nss_manual_check="yes"
@@ -674,9 +674,9 @@
 				NSS_LIBS="-L$with_nss_libs $nsslibs"
 
 				if test "$enable_nss" = "static"; then
-					msg_ssl="Mozilla NSS (static)"
+					msg_nss="Mozilla NSS (static)"
 				else
-					msg_ssl="Mozilla NSS"
+					msg_nss="Mozilla NSS"
 				fi
 
 				enable_nss="yes"
@@ -701,6 +701,14 @@
 
 AM_CONDITIONAL(USE_NSS, test "x$enable_nss" = "xyes")
 
+if test "x$msg_nss" != "x" -a "x$msg_gnutls" != "x"; then
+	msg_ssl="$msg_nss and $msg_gnutls"
+elif test "x$msg_nss" != "x"; then
+	msg_ssl=$msg_nss
+elif test "x$msg_gnutls" != "x"; then
+	msg_ssl=$msg_gnutls
+fi
+
 dnl Check for Tcl
 if test "$enable_tcl" = yes; then
 	AC_MSG_CHECKING([for tclConfig.sh])
@@ -964,7 +972,7 @@
 echo Protocols to link statically.. : $STATIC_PRPLS
 echo
 echo UI Library.................... : GTK 2.x
-echo SSL Library................... : $msg_ssl
+echo SSL Library/Libraries......... : $msg_ssl
 echo
 echo Build with Plugin support..... : $enable_plugins
 echo Build with Perl support....... : $enable_perl