diff libpurple/Makefile.am @ 18587:66f2354fb0fd

move STATIC_LINK_LIBS up in link order to ensure its dependencies get included properly. Patch #2216 from IgorVlasenko
author Sean Egan <seanegan@gmail.com>
date Sat, 21 Jul 2007 19:31:08 +0000
parents 95731e366df2
children cc41918086bd 4167e2d7ebef
line wrap: on
line diff
--- a/libpurple/Makefile.am	Sat Jul 21 05:53:05 2007 +0000
+++ b/libpurple/Makefile.am	Sat Jul 21 19:31:08 2007 +0000
@@ -225,11 +225,11 @@
 libpurple_la_DEPENDENCIES = $(STATIC_LINK_LIBS)
 libpurple_la_LDFLAGS = -export-dynamic -version-info $(PURPLE_LT_VERSION_INFO) -no-undefined
 libpurple_la_LIBADD = \
+	$(STATIC_LINK_LIBS) \
 	$(DBUS_LIBS) \
 	$(GLIB_LIBS) \
 	$(LIBXML_LIBS) \
 	$(LIBNM_LIBS) \
-	$(STATIC_LINK_LIBS) \
 	$(INTLLIBS) \
 	-lm