diff console/plugins/Makefile.am @ 14674:69590c55c748

[gaim-migrate @ 17420] It is more correct to use foo_la_LIBADD to specify libs to link to instead of foo_la_LDFLAGS committer: Tailor Script <tailor@pidgin.im>
author Stu Tomlinson <stu@nosnilmot.com>
date Sun, 01 Oct 2006 18:17:49 +0000
parents a2b56d168a88
children 04f03667702f
line wrap: on
line diff
--- a/console/plugins/Makefile.am	Sun Oct 01 16:33:14 2006 +0000
+++ b/console/plugins/Makefile.am	Sun Oct 01 18:17:49 2006 +0000
@@ -1,5 +1,5 @@
-gntgf_la_LDFLAGS      = -module -avoid-version $(GLIB_LIBS) $(X11_LIBS) $(GNT_LIBS)
-gnthistory_la_LDFLAGS = -module -avoid-version $(GLIB_LIBS)
+gntgf_la_LDFLAGS      = -module -avoid-version
+gnthistory_la_LDFLAGS = -module -avoid-version
 
 if PLUGINS
 
@@ -12,6 +12,9 @@
 gntgf_la_SOURCES      = gntgf.c
 gnthistory_la_SOURCES = gnthistory.c
 
+gntgf_la_LIBADD       = $(GLIB_LIBS) $(X11_LIBS) $(top_builddir)/console/libgnt/libgnt.la
+gnthistory_la_LIBADD  = $(GLIB_LIBS)
+
 endif # PLUGINS
 
 EXTRA_DIST =