diff libgaim/protocols/zephyr/Makefile.am @ 14674:69590c55c748

[gaim-migrate @ 17420] It is more correct to use foo_la_LIBADD to specify libs to link to instead of foo_la_LDFLAGS committer: Tailor Script <tailor@pidgin.im>
author Stu Tomlinson <stu@nosnilmot.com>
date Sun, 01 Oct 2006 18:17:49 +0000
parents 60b1bc8dbf37
children
line wrap: on
line diff
--- a/libgaim/protocols/zephyr/Makefile.am	Sun Oct 01 16:33:14 2006 +0000
+++ b/libgaim/protocols/zephyr/Makefile.am	Sun Oct 01 18:17:49 2006 +0000
@@ -73,7 +73,7 @@
 
 ZEPHYRLIBSEXT = $(ZEPHYR_LDFLAGS) $(ZEPHYR_LIBS)
 
-libzephyr_la_LDFLAGS = -module -avoid-version $(GLIB_LIBS)
+libzephyr_la_LDFLAGS = -module -avoid-version
 
 if STATIC_ZEPHYR
 
@@ -90,10 +90,10 @@
 
 if EXTERNAL_LIBZEPHYR
 libzephyr_la_SOURCES = $(ZEPHYRSOURCESEXT)
-libzephyr_la_LIBADD = $(ZEPHYRLIBSEXT)
+libzephyr_la_LIBADD = $(GLIB_LIBS) $(ZEPHYRLIBSEXT)
 else
 libzephyr_la_SOURCES = $(ZEPHYRSOURCES)
-libzephyr_la_LIBADD  = $(ZEPHYRLIBS)
+libzephyr_la_LIBADD  = $(GLIB_LIBS) $(ZEPHYRLIBS)
 endif