diff Makefile.am @ 25741:7183d12b96ed

propagate from branch 'im.pidgin.pidgin' (head 311b4db51b575e1baa7f78d751ff926475edecc3) to branch 'im.pidgin.cpw.malu.xmpp.ibb_ft' (head 2547f95c32d530b4f5c2d0cb5e65860482dc8138)
author Marcus Lundblad <ml@update.uu.se>
date Thu, 13 Nov 2008 19:50:53 +0000
parents b31d2ca01b7a
children e5efa83aa6d2 d1a4088528ce
line wrap: on
line diff
--- a/Makefile.am	Wed Oct 29 21:38:33 2008 +0000
+++ b/Makefile.am	Thu Nov 13 19:50:53 2008 +0000
@@ -30,7 +30,12 @@
 distcheck-hook: libpurple/plugins/perl/common/Purple.pm pidgin/plugins/perl/common/Pidgin.pm
 #	cp libpurple/plugins/perl/common/Gaim.pm $(distdir)/libpurple/plugins/perl/common
 
-version-check:
+commit-check:
+	(cd po ; intltool-update -m 2>&1 | grep -v '^mismatched quotes.*\.py$$' | sed "s|current directory|po directory|" | grep . ; if [ $$? = 0 ] ; then exit 1 ; else exit 0 ; fi)
+	LC_ALL=C sort -c -t/ -u po/POTFILES.in
+	LC_ALL=C sort -c -t/ -u po/POTFILES.skip
+
+version-check: commit-check
 # We don't want to release development versions.
 	test x`echo $(PACKAGE_VERSION) | grep dev` = x