diff configure.ac @ 13323:723f5b7ef6a2

[gaim-migrate @ 15693] Long long ago, in a far-off land, a patch was sent to gaim-devel... I modified this patch, but couldn't test it, so it sat. Today, I got to borrow an evaluation laptop from Apple (here at the University of Minnesota, Crookston). So, I bring you... A patch from Michael Culbertson: On Mac OS X, obtain the system idle time via IOKit. Thus, our idle time calculations will reflect system usage rather than X11 application usage. committer: Tailor Script <tailor@pidgin.im>
author Richard Laager <rlaager@wiktel.com>
date Fri, 24 Feb 2006 03:38:09 +0000
parents d5bfc701e1e5
children c1f5d9858c1d
line wrap: on
line diff
--- a/configure.ac	Fri Feb 24 02:16:25 2006 +0000
+++ b/configure.ac	Fri Feb 24 03:38:09 2006 +0000
@@ -25,6 +25,14 @@
 case "$host_os" in
 darwin*)
 	AC_CHECK_LIB(resolv, res_query)
+
+	AC_CHECK_HEADER(CoreFoundation/CoreFoundation.h, [
+		AC_CHECK_HEADER(IOKit/IOKitLib.h, [
+			AC_DEFINE(HAVE_IOKIT, 1, [Define if we have IOKit])
+			LIBS="$LIBS -framework IOKit -framework CoreFoundation"
+		], [])
+	], [])
+
 	AC_MSG_CHECKING([for fink])
 	if test -d /sw; then
 		AC_MSG_RESULT([found, adding /sw to search paths])
@@ -264,7 +272,7 @@
 #include <silcmime.h>
 		], [], [
 		AC_MSG_RESULT(yes)
-		AC_DEFINE(HAVE_SILCMIME_H, 1, [define if we have silcmime.h])
+		AC_DEFINE(HAVE_SILCMIME_H, 1, [Define if we have silcmime.h])
 		], [
 		AC_MSG_RESULT(no)
 		])