diff Makefile.am @ 30250:74541f1faf3c

merge of '5aacaf467359c75ac94de8b4a1897a191bc2a261' and '5cf492b57fa4a297212cbaa711deb42e1e431a08'
author Marcus Lundblad <ml@update.uu.se>
date Wed, 07 Jul 2010 20:06:35 +0000
parents a14c2e81fcf0
children a7cf3dbaba02 3b4e12c42d3c
line wrap: on
line diff
--- a/Makefile.am	Wed Jul 07 20:04:06 2010 +0000
+++ b/Makefile.am	Wed Jul 07 20:06:35 2010 +0000
@@ -100,18 +100,18 @@
 # creates, and also make sure that the shell command exits
 # successfully; the rm -f ensures both
 package_revision_raw.txt:
-	REAL_BLDDIR=$$PWD/$(top_builddir); \
+	$(AM_V_GEN)REAL_BLDDIR=$$PWD/$(top_builddir); \
 	(cd $(srcdir) && $$REAL_BLDDIR/mtn --root=. automate get_base_revision_id) 2>/dev/null >$@ \
 	|| (cd $(srcdir) && mtn --root=. automate get_base_revision_id) 2>/dev/null >$@ \
 	|| rm -f $@
 package_revision.h: package_revision_raw.txt
-	if test -f $<; then \
+	$(AM_V_GEN)if test -f $<; then \
 	  echo "#define REVISION \"`cat $<`\"" > $@; \
 	fi
-	if test ! -f $@ -a -f $(srcdir)/$@; then \
+	$(AM_V_at)if test ! -f $@ -a -f $(srcdir)/$@; then \
 	  cp $(srcdir)/$@ $@; \
 	fi
-	test -f $@ || echo "#define REVISION \"unknown\"" > $@
+	$(AM_V_at)test -f $@ || echo "#define REVISION \"unknown\"" > $@
 
 # This is a magic directive copy-and-pasted, then modified, from the
 # automake 1.9 manual, section 13.4, "Checking the distribution".