diff configure.ac @ 27093:77177e6000e4

Install the Purple and Pidgin perl modules under $libdir instead of in perl's normal @INC locations. Since they aren't usable by perl directly existing there just confused people and conflicted with similarly named perl modules. Thanks Zsombor Welker. Fixes #5428
author Etan Reisner <pidgin@unreliablesource.net>
date Thu, 18 Jun 2009 23:01:51 +0000
parents b709ab0cb4bc
children 552b5292f36f
line wrap: on
line diff
--- a/configure.ac	Thu Jun 18 22:48:49 2009 +0000
+++ b/configure.ac	Thu Jun 18 23:01:51 2009 +0000
@@ -1563,30 +1563,6 @@
 			AC_MSG_RESULT(no)
 		fi
 
-		if test "x$prefix" != "xNONE"; then
-			prefix=`eval echo $prefix`
-			PERL_MM_PARAMS="INSTALLDIRS=vendor PREFIX=$prefix"
-		fi
-
-		AC_ARG_WITH(perl-lib,
-		[AC_HELP_STRING([--with-perl-lib=[site|vendor|DIR]],
-			[specify where to install the Perl libraries for pidgin. Default is site.])],
-		[
-			if test "x$withval" = xsite; then
-				PERL_MM_PARAMS=""
-			elif test "x$withval" = xvendor; then
-				if test -z "`$perlpath -v | grep '5\.0'`"; then
-					PERL_MM_PARAMS="INSTALLDIRS=vendor"
-				else
-					PERL_MM_PARAMS="INSTALLDIRS=vendor PREFIX=`perl -e 'use Config; print $Config{prefix}'`"
-				fi
-			else
-				PERL_MM_PARAMS="INSTALLDIRS=vendor PREFIX=$withval"
-			fi
-		])
-
-		AC_SUBST(PERL_MM_PARAMS)
-
 		AC_MSG_CHECKING(for DynaLoader.a)
 		DYNALOADER_A=`echo $PERL_LDFLAGS | $perlpath -pe 's/^(.* )*([[^ ]]*DynaLoader\.a).*/\2/'`