diff console/plugins/Makefile.am @ 14223:7c560c01b8f9

[gaim-migrate @ 16904] Add a plugin gnthistory. The plugin is a core plugin, but does not look good in gtkgaim. committer: Tailor Script <tailor@pidgin.im>
author Sadrul Habib Chowdhury <imadil@gmail.com>
date Sun, 20 Aug 2006 16:45:57 +0000
parents 44ec6c7cbc76
children 9e9699792bb9
line wrap: on
line diff
--- a/console/plugins/Makefile.am	Sun Aug 20 16:38:10 2006 +0000
+++ b/console/plugins/Makefile.am	Sun Aug 20 16:45:57 2006 +0000
@@ -1,27 +1,29 @@
 gntgf_la_LDFLAGS             = -module -avoid-version $(GLIB_LIBS)
+gnthistory_la_LDFLAGS             = -module -avoid-version $(GLIB_LIBS)
 
 if PLUGINS
 
 plugin_LTLIBRARIES = \
-	gntgf.la
+	gntgf.la \
+	gnthistory.la
 
 plugindir = $(libdir)/gaim
 
 gntgf_la_SOURCES             = gntgf.c
+gnthistory_la_SOURCES        = gnthistory.c
 
 endif # PLUGINS
 
 EXTRA_DIST = 
 
-GNT_CFLAGS = `pkg-config --cflags gnt` -I..
-
 AM_CPPFLAGS = \
 	-DDATADIR=\"$(datadir)\" \
 	-DVERSION=\"$(VERSION)\" \
-	-I$(top_builddir)/src \
-	-I$(top_srcdir)/src \
+	-I$(top_builddir)/libgaim \
+	-I$(top_srcdir)/libgaim \
+	-I$(top_srcdir)/console \
+	-I$(top_srcdir)/console/libgnt \
 	$(DEBUG_CFLAGS) \
-	$(GNT_CFLAGS) \
 	$(GLIB_CFLAGS) \
 	$(PLUGIN_CFLAGS)