diff libpurple/Makefile.am @ 27635:7fbf964c6c6c

Move the IDN support into the DNS routines. This turned out to be cleaner than I first thought, so here we go. All libpurple DNS routines support IDN when built against GNU libidn.
author Paul Aurich <paul@darkrain42.org>
date Sun, 19 Jul 2009 23:45:13 +0000
parents a50d0b8e3b7d
children c1314a6cefcf
line wrap: on
line diff
--- a/libpurple/Makefile.am	Sun Jul 19 22:40:10 2009 +0000
+++ b/libpurple/Makefile.am	Sun Jul 19 23:45:13 2009 +0000
@@ -293,6 +293,7 @@
 	$(FARSIGHT_LIBS) \
 	$(GSTREAMER_LIBS) \
 	$(GSTINTERFACES_LIBS) \
+	$(IDN_LIBS) \
 	-lm
 
 AM_CPPFLAGS = \
@@ -308,6 +309,7 @@
 	$(FARSIGHT_CFLAGS) \
 	$(GSTREAMER_CFLAGS) \
 	$(GSTINTERFACES_CFLAGS) \
+	$(IDN_CFLAGS) \
 	$(NETWORKMANAGER_CFLAGS)
 
 # INSTALL_SSL_CERTIFICATES is true when SSL_CERTIFICATES_DIR is empty.