diff configure.ac @ 4430:801830dec409

[gaim-migrate @ 4705] robot101 gave me a bad patch committer: Tailor Script <tailor@pidgin.im>
author Luke Schierer <lschiere@pidgin.im>
date Sun, 26 Jan 2003 20:43:25 +0000
parents bf770f11132b
children 58c3c6cfd537
line wrap: on
line diff
--- a/configure.ac	Sun Jan 26 20:41:49 2003 +0000
+++ b/configure.ac	Sun Jan 26 20:43:25 2003 +0000
@@ -122,7 +122,10 @@
 AC_DEFINE_UNQUOTED(STATIC_PROTO_INIT, $extern_init void static_proto_init() { $load_proto },
 	[Loads static protocol plugin module initialization functions.])
 
-AC_ARG_ENABLE(audio,   [  --disable-audio         compile without libao/libaudiofile for sound playing],,enable_audio=yes)
+AC_ARG_ENABLE(esd,     [  --disable-esd           Turn off ESD (default=auto)],,enable_esd=yes)
+AC_ARG_ENABLE(nas,     [  --enable-nas            Enable NAS (Network Audio System) support],,enable_nas=no)
+AC_ARG_ENABLE(artsc,   [  --disable-artsc         Turn off ArtsC (default=auto)],,enable_artsc=yes)
+
 AC_ARG_ENABLE(plugins, [  --disable-plugins       compile without plugin support],,enable_plugins=yes)
 AC_ARG_ENABLE(perl,    [  --disable-perl          compile without perl scripting],,enable_perl=yes)
 AC_ARG_ENABLE(gtkspell, [  --disable-gtkspell      compile without GtkSpell automatic spell checking],,enable_gtkspell=yes)
@@ -271,28 +274,45 @@
 	fi
 fi
 
-if test "$enable_audio" = yes ; then
-	AC_CHECK_HEADERS(ao/ao.h, found_ao_lib=true, found_ao_lib=false)
-	if test "$found_ao_lib" = "true"; then
-		AC_CHECK_LIB(ao, ao_initialize, found_ao_lib=true, found_ao_lib=false)
-	fi
-
-	AC_CHECK_HEADERS(audiofile.h, found_af_lib=true, found_af_lib=false)
-	if test "$found_af_lib" = "true"; then
-		AC_CHECK_LIB(audiofile, afOpenFile, found_af_lib=true, found_af_lib=false)
+if test "$enable_nas" = yes ; then
+	AC_DEFINE(NAS_SOUND, 1, [Define if we have NAS sound support.])
+        SOUND_LIBS="-laudio -lXt"
+fi
+if test "$enable_esd" = yes ; then
+	AM_PATH_GESD
+        if test "$no_esd" != yes ; then
+		old_CFLAGS="$CFLAGS"
+        	CFLAGS="$CFLAGS $ESD_CFLAGS"
+		AC_TRY_COMPILE(,[#include <esd.h>],
+			[
+				AC_DEFINE(ESD_SOUND, 1, [Define if we have ESD sound support.])
+				SOUND_LIBS="$SOUND_LIBS $ESD_LIBS"
+			],[
+				enable_esd=no
+				CFLAGS="$old_CFLAGS"
+			])
+	else
+		enable_esd=no
+        fi
+fi
+if test "x$enable_artsc" = "xyes"; then
+	AM_PATH_ARTSC
+	if test "x$no_artsc" != "xyes" ; then
+		old_CFLAGS="$CFLAGS"
+		CFLAGS="$CFLAGS $ARTSC_CFLAGS"
+		AC_TRY_COMPILE(,[#include <artsc.h>],
+			[
+				AC_DEFINE(ARTSC_SOUND, 1, [Define if we have artsc sound support.])
+				SOUND_LIBS="$SOUND_LIBS $ARTSC_LIBS"
+			],[
+				enable_artsc=no
+				CFLAGS="$old_CFLAGS"
+			])
+	else
+		enable_artsc=no
 	fi
-
-	if test "$found_ao_lib" = "true" -a "$found_af_lib" = "true"; then
-		SOUND_LIBS="-lao -laudiofile"
-		AC_SUBST(SOUND_LIBS)
-		AC_DEFINE(USE_AO, 1, [Define if we're using libao and libaudiofile for sound playing])
-		enable_audio=yes
-	else
-		enable_audio=no
-	fi
-else
-	enable_audio=no
 fi
+AC_SUBST(SOUND_LIBS)
 
 if test "$ac_cv_cygwin" = yes ; then
 	LDADD="$LDADD -static"
@@ -422,16 +442,20 @@
 echo Build Protocol Plugins........ : $enable_prpls
 echo Protocols to link statically.. : $STATIC_PRPLS
 echo
-echo UI Library.................... : GTK 2.x
+echo UI Library.................... : GTK 2.0
 echo
 echo Build with Plugin support..... : $enable_plugins
 echo Build with Perl support....... : $enable_perl
-echo Build with Audio support...... : $enable_audio
-echo Build with GtkSpell support... : $enable_gtkspell
+echo
+echo Build with GtkSpell............: $enable_gtkspell
 echo
 echo Use XScreenSaver Extension.... : $enable_xss
 echo Use X Session Management...... : $enable_sm
 echo
+echo Build with ESD................ : $enable_esd
+echo Build with NAS................ : $enable_nas
+echo Build with ArtsC.............. : $enable_artsc
+echo
 echo Print debugging messages...... : $enable_debug
 echo
 eval eval echo Gaim will be installed in $bindir.