diff libgaim/Makefile.am @ 14520:82b59abcaee4

[gaim-migrate @ 17240] SF Patch #1492561 from Lars T. Mikkelsen "This patch adds gaim-url-handler, a URL handler for most protocols in Gaim. The gaim-url-handler is similar to (and based on) gaim-remote, however, it uses the native URL format of each protocol. Furthermore, the patch includes a GConf schema, which allows Gnome applications to use the URL handler." With this and gaim-send/gaim-send-async, we should be able to drop gaim-remote. Please let me know if you object, or I'll remove gaim-remote shortly. For the record, I know this doesn't support 100% of the ChatZilla IRC URL spec, and I haven't investigated the XMPP URL spec beyond a casual first look. We can tweak these things later -- I figured it was important to get the bulk of the code in place. committer: Tailor Script <tailor@pidgin.im>
author Richard Laager <rlaager@wiktel.com>
date Mon, 11 Sep 2006 02:30:59 +0000
parents bb99380c67c3
children 565f90ad0c84
line wrap: on
line diff
--- a/libgaim/Makefile.am	Mon Sep 11 02:02:18 2006 +0000
+++ b/libgaim/Makefile.am	Mon Sep 11 02:30:59 2006 +0000
@@ -5,6 +5,7 @@
 		gaim-remote \
 		gaim-send \
 		gaim-send-async \
+		gaim-url-handler \
 		Makefile.mingw \
 		win32/global.mak \
 		win32/libc_interface.c \
@@ -17,7 +18,11 @@
 		win32/win32dep.c \
 		win32/win32dep.h
 
-SUBDIRS = plugins protocols
+if USE_GCONFTOOL
+GCONF_DIR=gconf
+endif
+
+SUBDIRS = $(GCONF_DIR) plugins protocols
 
 gaim_coresources = \
 	account.c \
@@ -187,7 +192,7 @@
 
 # scripts
 
-bin_SCRIPTS = gaim-notifications-example gaim-remote gaim-send gaim-send-async
+bin_SCRIPTS = gaim-notifications-example gaim-remote gaim-send gaim-send-async gaim-url-handler
 
 endif