diff finch/plugins/Makefile.am @ 15891:886025ef7daa

Build gntclipboard plugin by default. If we don't want this, at least include gntclipboard.c in EXTRA_DIST so it gets included in tarballs
author Stu Tomlinson <stu@nosnilmot.com>
date Sat, 24 Mar 2007 20:41:40 +0000
parents c6e563dfaa7a
children 42c6d1d81bec
line wrap: on
line diff
--- a/finch/plugins/Makefile.am	Sat Mar 24 20:08:30 2007 +0000
+++ b/finch/plugins/Makefile.am	Sat Mar 24 20:41:40 2007 +0000
@@ -1,3 +1,4 @@
+gntclipboard_la_LDFLAGS = -module -avoid-version
 gntgf_la_LDFLAGS      = -module -avoid-version
 gnthistory_la_LDFLAGS = -module -avoid-version
 gntlastlog_la_LDFLAGS    = -module -avoid-version
@@ -5,18 +6,21 @@
 if PLUGINS
 
 plugin_LTLIBRARIES = \
+	gntclipboard.la \
 	gntgf.la \
 	gnthistory.la \
 	gntlastlog.la
 
 plugindir = $(libdir)/finch
 
+gntclipboard_la_SOURCES = gntclipboard.c
 gntgf_la_SOURCES      = gntgf.c
 gnthistory_la_SOURCES = gnthistory.c
 gntlastlog_la_SOURCES = lastlog.c
 
 gntgf_la_CFLAGS = $(X11_CFLAGS)
 
+gntclipboard_la_LIBADD = $(GLIB_LIBS)
 gntgf_la_LIBADD       = $(GLIB_LIBS) $(X11_LIBS) $(top_builddir)/finch/libgnt/libgnt.la
 gnthistory_la_LIBADD  = $(GLIB_LIBS)
 gntlastlog_la_LIBADD  = $(GLIB_LIBS)