diff libpurple/protocols/jabber/Makefile.am @ 28696:8ada06fb65ed

jabber: Factor the SASL auth methods into their own files. This works with and without Cyrus SASL, though there's room for cleanup and de-duplication (some code is now duplicated between auth.c and auth_cyrus.c).
author Paul Aurich <paul@darkrain42.org>
date Sat, 07 Nov 2009 06:10:17 +0000
parents e5fdfff98aa9
children 338eeaf371e2
line wrap: on
line diff
--- a/libpurple/protocols/jabber/Makefile.am	Sat Nov 07 04:41:04 2009 +0000
+++ b/libpurple/protocols/jabber/Makefile.am	Sat Nov 07 06:10:17 2009 +0000
@@ -7,6 +7,8 @@
 
 JABBERSOURCES = auth.c \
 			  auth.h \
+			  auth_digest_md5.c \
+			  auth_plain.c \
 			  buddy.c \
 			  buddy.h \
 			  bosh.c \
@@ -76,6 +78,10 @@
 
 libxmpp_la_LDFLAGS = -module -avoid-version
 
+if USE_CYRUS_SASL
+JABBERSOURCES += auth_cyrus.c
+endif
+
 if STATIC_JABBER
 
 st = -DPURPLE_STATIC_PRPL