diff libpurple/Makefile.am @ 23787:92e71f6e10d4

Patch from Marcus Lundblad ('mlundblad') to improve audio support in xmpp. It's now possible to initiate an audio session, sometimes. It's somewhat buggy. Some other issues also need to be resolved: * Properly get rid of the compile warnings * Rename the serv_ functions with proper namespacing. * Possibly rename the purple_media_ functions that don't deal with a PurpleMedia (e.g. purple_media_audio_init_src) to something different, e.g. purple_media_util_, or even purple_gst_util etc.
author Sadrul Habib Chowdhury <imadil@gmail.com>
date Sat, 22 Mar 2008 04:45:46 +0000
parents 60f5abc6cf0c
children e1c8ec1259de ff29208e03ef
line wrap: on
line diff
--- a/libpurple/Makefile.am	Tue Mar 18 05:40:29 2008 +0000
+++ b/libpurple/Makefile.am	Sat Mar 22 04:45:46 2008 +0000
@@ -251,6 +251,8 @@
 	$(LIBNM_LIBS) \
 	$(INTLLIBS) \
 	$(FARSIGHT_LIBS) \
+	$(GSTREAMER_LIBS) \
+	$(GSTPROPS_LIBS) \
 	-lm
 
 AM_CPPFLAGS = \
@@ -264,4 +266,6 @@
 	$(DBUS_CFLAGS) \
 	$(LIBXML_CFLAGS) \
 	$(FARSIGHT_CFLAGS) \
+	$(GSTREAMER_CFLAGS) \
+	$(GSTPROPS_CFLAGS) \
 	$(LIBNM_CFLAGS)